org.apache.xmlbeans.XmlException

S:\something\build\config\buildtools.xml:0: error: The document is not a xml-fragment@http://something/Buildtools: multiple document elements

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web131

  • via xmlbeans-user by Manoj Pansare, 1 year ago
    S:\something\build\config\buildtools.xml:0: error: The document is not a xml-fragment@http://something/Buildtools: multiple document elements
  • via xmlbeans-user by Manoj Pansare, 9 months ago
    S:\something\build\config\buildtools.xml:0: error: The document is not a xml-fragment@http://something/Buildtools: multiple document elements
  • via openbravopos by cheli-tictech
    , 11 months ago
    error: The document is not a soapui-project@http://eviware.com/soapui/config: document element mismatch got definitions@http://schemas.xmlsoap.org/wsdl/
  • Stack trace

    • org.apache.xmlbeans.XmlException: S:\something\build\config\buildtools.xml:0: error: The document is not a xml-fragment@http://something/Buildtools: multiple document elements at org.apache.xmlbeans.impl.store.Locale.verifyDocumentType(Locale.java:452) at org.apache.xmlbeans.impl.store.Locale.autoTypeDocument(Locale.java:357) at org.apache.xmlbeans.impl.store.Locale.parseToXmlObject(Locale.java:1273) at org.apache.xmlbeans.impl.store.Locale.parseToXmlObject(Locale.java:1257) at org.apache.xmlbeans.impl.schema.SchemaTypeLoaderBase.parse(SchemaTypeLoaderBase.java:345) at org.apache.xmlbeans.impl.schema.SchemaTypeLoaderBase.parse(SchemaTypeLoaderBase.java:252) at com.mathworks.x2010.bat.x01.propertyflattening.buildtools.XmlFragmentDocument$Factory.parse(Unknown Source) at com.mathworks.bat.server.propertyflattening.lib.BuildtoolsUpdaterNew.applyChanges(BuildtoolsUpdaterNew.java:32) at com.mathworks.bat.server.system.SystemTestPropertyFlatteningGeneral.testPropertyValueFlattening(SystemTestPropertyFlatteningGeneral.java:51) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at org.junit.internal.runners.TestMethod.invoke(TestMethod.java:59) at org.junit.internal.runners.MethodRoadie.runTestMethod(MethodRoadie.java:98) at org.junit.internal.runners.MethodRoadie$2.run(MethodRoadie.java:79) at org.junit.internal.runners.MethodRoadie.runBeforesThenTestThenAfters(MethodRoadie.java:87) at org.junit.internal.runners.MethodRoadie.runTest(MethodRoadie.java:77) at org.junit.internal.runners.MethodRoadie.run(MethodRoadie.java:42) at org.junit.internal.runners.JUnit4ClassRunner.invokeTestMethod(JUnit4ClassRunner.java:88) at org.junit.internal.runners.JUnit4ClassRunner.runMethods(JUnit4ClassRunner.java:51) at org.junit.runners.Parameterized$TestClassRunnerForParameters.run(Parameterized.java:98) at org.junit.internal.runners.CompositeRunner.runChildren(CompositeRunner.java:33) at org.junit.runners.Parameterized.access$000(Parameterized.java:55) at org.junit.runners.Parameterized$1.run(Parameterized.java:131) at org.junit.internal.runners.ClassRoadie.runUnprotected(ClassRoadie.java:27) at org.junit.internal.runners.ClassRoadie.runProtected(ClassRoadie.java:37) at org.junit.runners.Parameterized.run(Parameterized.java:129) at org.eclipse.jdt.internal.junit4.runner.JUnit4TestReference.run(JUnit4TestReference.java:49) at org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:467) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:683) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:390) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:197)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 11 months ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago