javax.net.ssl.SSLHandshakeException: com.android.org.bouncycastle.jce.exception.ExtCertPathValidatorException: Could not validate certificate: Certificate not valid until Mon May 23 12:00:00 GMT+12:00 2016 (compared to Sun Feb 23 19:10:30 GMT+13:00 2014)

GitHub | EzlyJohnnie | 8 months ago
tip
Click on the to mark the solution that helps you, Samebug will learn from it.
As a community member, you’ll be rewarded for you help.
  1. 0

    GitHub comment 6552#251077219

    GitHub | 8 months ago | EzlyJohnnie
    javax.net.ssl.SSLHandshakeException: com.android.org.bouncycastle.jce.exception.ExtCertPathValidatorException: Could not validate certificate: Certificate not valid until Mon May 23 12:00:00 GMT+12:00 2016 (compared to Sun Feb 23 19:10:30 GMT+13:00 2014)
  2. 0

    Security, expire sert

    GitHub | 2 years ago | xoyteam
    java.security.cert.CertificateException: com.android.org.bouncycastle.jce.exception.ExtCertPathValidatorException: Could not validate certificate: null
  3. 0

    HLS Playback on Android 6.0 (M) / Demo player

    GitHub | 2 years ago | piterwilson
    com.google.android.exoplayer.upstream.HttpDataSource$HttpDataSourceException: Unable to connect to https://devimages.apple.com.edgekey.net/streaming/examples/bipbop_4x3/bipbop_4x3_variant.m3u8
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    IssueImageUpload Error: com.bugtags.library.obfuscated.am: javax.net.ssl.SSLHandshakeException:

    GitHub | 7 months ago | jp1017
    javax.net.ssl.SSLHandshakeException: com.android.org.bouncycastle.jce.exception.ExtCertPathValidatorException: Could not validate certificate: null

  1. Hiren 5 times, last 6 days ago
  2. iridic 1 times, last 6 months ago
  3. Stefan Braune 1 times, last 10 months ago
  4. Diogo Jaym 3 times, last 11 months ago
  5. dmitry 3 times, last 1 year ago
2 more registered users
1 unregistered visitors

Root Cause Analysis

  1. com.android.org.bouncycastle.jce.exception.ExtCertPathValidatorException

    Could not validate certificate: Certificate not valid until Mon May 23 12:00:00 GMT+12:00 2016 (compared to Sun Feb 23 19:10:30 GMT+13:00 2014)

    at com.android.org.bouncycastle.jce.provider.RFC3280CertPathUtilities.processCertA()
  2. RoboVM
    PKIXCertPathValidatorSpi.engineValidate
    1. com.android.org.bouncycastle.jce.provider.RFC3280CertPathUtilities.processCertA(RFC3280CertPathUtilities.java:1492)
    2. com.android.org.bouncycastle.jce.provider.PKIXCertPathValidatorSpi.engineValidate(PKIXCertPathValidatorSpi.java:305)
    2 frames