Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

  1. ,
    via Google Groups by Marcus Haebler

    Update "latest" to Java 8 on DockerHub.

  2. ,
    via Stack Overflow by ERJAN

    This exception occurs when using an older version of java. Mainly when trying to run a jar compiled with a newer Java version in an older Java version. We can avoid this issue by executing the jar in the same version which it was compiled.

Solutions on the web

via Coderanch by Tontang Bei, 1 year ago
Bad version number in .class f e
via Oracle Community by 843810, 2 years ago
via Coderanch by Tontang Bei, 1 year ago
Bad version number in .class file
via GitHub by GoogleCodeExporter
, 2 years ago
Bad version number in .class file
via GitHub by mbastian
, 2 years ago
Bad version number in .class file
java.lang.UnsupportedClassVersionError: Bad version number in .class f e at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(Unknown Source) at java.security.SecureClassLoader.defineClass(Unknown Source) at java.net.URLClassLoader.defineClass(Unknown Source) at java.net.URLClassLoader.access$100(Unknown Source) at java.net.URLClassLoader$1.run(Unknown Source) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClassInternal(Unknown Source)