java.lang.NoClassDefFoundError

x/Xi (wrong name: X/X i) [error]I used x instead of X[/error]

Samebug tips1

Look if your classpath is correct, and check if the versions of your libraries match the version you described in your pom.xml

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web2574

  • via Coderanch by Campbell Ritchie, 9 months ago
    x/Xi (wrong name: X/X i) [error]I used x instead of X[/error]
  • via Google Groups by keffe, 1 year ago
    x (wrong name: tests/ x)
  • via GitHub by desmondoz
    , 1 year ago
    x
  • Stack trace

    • java.lang.NoClassDefFoundError: x/Xi (wrong name: X/X i) [error]I used x instead of X[/error] at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(Unknown Source) at java.security.SecureClassLoader.defineClass(Unknown Source) at java.net.URLClassLoader.defineClass(Unknown Source) at java.net.URLClassLoader.access$000(Unknown Source) at java.net.URLClassLoader$1.run(Unknown Source) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClass(Unknown Source) at java.lang.ClassLoader.loadClassInternal(Unknown Source)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 1 year ago
    Once, 2 days ago
    Once, 1 month ago
    12 times, 1 month ago
    Unknown user
    Once, 2 months ago
    139 more bugmates