java.lang.NoClassDefFoundError

org/apache/struts/action/Action Check you classpath do you really have the struts2 jars in your WEB-INF/lib folder? Johannes ################################################# web: http://www.jgeppert.com twitter: http://twitter.com/jogep 2015-02-07 7:08 GMT+01:00 Alireza Fattahi <afattahi@yahoo.com.invalid>: The project uses jCaptcha 1.0, after upgrading from 2.3.16 to Struts 2.3.20 the application could not start. Our project is not using jCaptcha struts integration, so we do not have and jCaptcha configuration ins strust.xml or web.xml, for instance we do **NOT** have below line in struts.xml <plug-in className="com.octo.captcha.module.struts.CaptchaServicePlugin"/> I think some plugin management mechanism is changed so the struts 2.3.20 try to find and start this plugin while 2.3.16 didn't. The error is as below: ERROR finder.ClassFinder Unable to read class [com.octo.captcha.module.struts.image.RenderImageCaptchaAction] Could not load org/apache/struts/action/Action.class - [unknown location]

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web25993

  • via struts-user by Johannes Geppert, 9 months ago
    7:08 GMT+01:00 Alireza Fattahi <afattahi@yahoo.com.invalid>: The project uses jCaptcha 1.0, after upgrading from 2.3.16 to Struts 2.3.20 the application could not start. Our project is not using jCaptcha struts integration, so we do not have and
  • via struts-user by Johannes Geppert, 9 months ago
    7:08 GMT+01:00 Alireza Fattahi <afattahi@yahoo.com.invalid>: The project uses jCaptcha 1.0, after upgrading from 2.3.16 to Struts 2.3.20 the application could not start. Our project is not using jCaptcha struts integration, so we do not have and
  • via apache.org by Unknown author, 1 year ago
    7:08 GMT+01:00 Alireza Fattahi <afattahi@yahoo.com.invalid>: The project uses jCaptcha 1.0, after upgrading from 2.3.16 to Struts 2.3.20 the application could not start. Our project is not using jCaptcha struts integration, so we do not have and
  • Stack trace

    • java.lang.NoClassDefFoundError: org/apache/struts/action/Action Check you classpath do you really have the struts2 jars in your WEB-INF/lib folder? Johannes ################################################# web: http://www.jgeppert.com twitter: http://twitter.com/jogep 2015-02-07 7:08 GMT+01:00 Alireza Fattahi <afattahi@yahoo.com.invalid>: The project uses jCaptcha 1.0, after upgrading from 2.3.16 to Struts 2.3.20 the application could not start. Our project is not using jCaptcha struts integration, so we do not have and jCaptcha configuration ins strust.xml or web.xml, for instance we do **NOT** have below line in struts.xml <plug-in className="com.octo.captcha.module.struts.CaptchaServicePlugin"/> I think some plugin management mechanism is changed so the struts 2.3.20 try to find and start this plugin while 2.3.16 didn't. The error is as below: ERROR finder.ClassFinder Unable to read class [com.octo.captcha.module.struts.image.RenderImageCaptchaAction] Could not load org/apache/struts/action/Action.class - [unknown location] at com.opensymphony.xwork2.util.finder.ClassFinder.readClassDef(ClassFinder.java:723) at com.opensymphony.xwork2.util.finder.ClassFinder.access$400(ClassFinder.java:71) at com.opensymphony.xwork2.util.finder.ClassFinder$InfoBuildingClassVisitor.extractSuperInterfaces(ClassFinder.java:770) at com.opensymphony.xwork2.util.finder.ClassFinder$InfoBuildingClassVisitor.visit(ClassFinder.java:757) at org.objectweb.asm.ClassReader.accept(Unknown Source) at org.objectweb.asm.ClassReader.accept(Unknown Source)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    You’re the first here who have seen this exception.