java.lang.UnsupportedClassVersionError

tip

Update "latest" to Java 8 on DockerHub.

tip

You're using an older version of java with classes compiled for java7

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • Unable to update openlayer on mf1t
    via GitHub by sbrunner
    ,
  • JDK1.7 requirements
    via GitHub by florianleibert
    ,
  • .2 version failure
    via GitHub by lighthouse65
    ,
    • java.lang.UnsupportedClassVersionError: org/plovr/cli/Main : Unsupported major.minor version 51.0 at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631) at java.lang.ClassLoader.defineClass(ClassLoader.java:615) at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141) at java.net.URLClassLoader.defineClass(URLClassLoader.java:283) at java.net.URLClassLoader.access$000(URLClassLoader.java:58) at java.net.URLClassLoader$1.run(URLClassLoader.java:197) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:190) at java.lang.ClassLoader.loadClass(ClassLoader.java:306) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301) at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

    Users with the same issue

    chenjunjunchenjunjun
    1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    193 more bugmates