org.osgi.framework.BundleException: Unresolved constraint in bundle org.protege.editor.owl.codegeneration [9]: Unable to resolve 9.0: missing requirement [9.0] osgi.wiring.package; (osgi.wiring.package=javax.swing)

stanford.edu | 2 months ago
  1. 0

    [protege-user] Fwd: Installing Protege 4.3 for linux 64 bit

    stanford.edu | 2 months ago
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.protege.editor.owl.codegeneration [9]: Unable to resolve 9.0: missing requirement [9.0] osgi.wiring.package; (osgi.wiring.package=javax.swing)
  2. 0

    Java 8 issue with Pax Exam chapter10-recipe-simple

    GitHub | 2 years ago | deklanowski
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.exam.extender.service [3]: Unable to resolve 3.0: missing requirement [3.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.4.0)(!(version>=2.0.0))) [caused by: Unable to resolve 5.0: missing requirement [5.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)]
  3. 0

    GLASSFISH 3 DOMAIN SERVICE ERROR

    Stack Overflow | 2 years ago | DES
    org.osgi.framework.BundleException: Unresolved constraint in bundle jaxb-api [2] : Unable to resolve 2.0: missing requirement [2.0] osgi.wiring.package; (osgi.wi ring.package=javax.activation)
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    [Neo4j] How to embed neo4j to OSGI env without spring?

    Google Groups | 6 years ago | Super Wang
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.neo4j.graph-algo [3]: Unable to resolve 3.0: missing requirement [3.0] package; (&(package=org.neo4j.graphdb)(version>=1.4.0)) [caused by: Unable to resolve 4.0: missing requirement [4.0] package; (package=com.sun.source.tree)]
  6. 0

    Apache Felix - Users - Unable to start Felix with gogo under tomcat

    nabble.com | 1 year ago
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.webconsole [1]: Unable to resolve 1.0: missing requirement [1.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.http)(version>=1.2.0)(!(version>=2.0.0))) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3974)

  1. davidvanlaatum 14 times, last 2 months ago
Not finding the right solution?
Take a tour to get the most out of Samebug.

Tired of useless tips?

Automated exception search integrated into your IDE

Root Cause Analysis

  1. org.osgi.framework.BundleException

    Unresolved constraint in bundle org.protege.editor.owl.codegeneration [9]: Unable to resolve 9.0: missing requirement [9.0] osgi.wiring.package; (osgi.wiring.package=javax.swing)

    at org.apache.felix.framework.Felix.resolveBundleRevision()
  2. Apache Felix Framework
    Felix.setActiveStartLevel
    1. org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3818)
    2. org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
    3. org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
    3 frames