org.osgi.framework.BundleException: Unresolved constraint in bundle CitizenRandomOsgiProjectExample [1]: Unable to resolve 1.0: missing requirement [1.0] osgi.wiring.package; (osgi.wiring.package=org.joda.convert)

utl.pt | 4 months ago
tip
Click on the to mark the solution that helps you, Samebug will learn from it.
As a community member, you’ll be rewarded for you help.
  1. 0

    Managing OSGi Transitive Dependencies (Part 2): Joda-Time Simple Example | CitizenRandom

    utl.pt | 4 months ago
    org.osgi.framework.BundleException: Unresolved constraint in bundle CitizenRandomOsgiProjectExample [1]: Unable to resolve 1.0: missing requirement [1.0] osgi.wiring.package; (osgi.wiring.package=org.joda.convert)
  2. 0

    GitHub comment 45#191943607

    GitHub | 1 year ago | tolbertam
    org.osgi.framework.BundleException: Unresolved constraint in bundle com.datastax.driver.core [13]: Unable to resolve 13.0: missing requirement [13.0] osgi.wiring.package; (&(osgi.wiring.package=jnr.ffi)(version>=2.0.0)(!(version>=3.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] osgi.wiring.package; (osgi.wiring.package=com.kenai.jffi)]
  3. 0

    CR3 is broken, doesn't start with JRE 8

    GitHub | 3 years ago | pires
    org.osgi.framework.BundleException: Unresolved constraint in bundle gravia-runtime-osgi [58]: Unable to resolve 58.0: missing requirement [58.0] osgi.wiring.package; (osgi.wiring.package=org.jboss.gravia.resource) [caused by: Unable to resolve 57.0: missing requirement [57.0] osgi.wiring.package; (osgi.wiring.package=javax.management)]
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Unable to undeloy osgi if correct Activator is not specified

    GitHub | 3 years ago | wezell
    org.osgi.framework.BundleException: Unresolved constraint in bundle plugin-dotcms-actionlet-pushnow [7]: Unable to resolve 7.0: missing requirement [7.0] osgi.wiring.package; (&(osgi.wiring.package=com.dotcms.plugin.email.osgi)(version>=0.0.0))
  6. 0

    Java 8 issue with Pax Exam chapter10-recipe-simple

    GitHub | 2 years ago | deklanowski
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.exam [1]: Unable to resolve 1.0: missing requirement [1.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.5.0)) [caused by: Unable to resolve 5.0: missing requirement [5.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)]

  1. davidvanlaatum 2631 times, last 7 months ago
6 unregistered visitors
Not finding the right solution?
Take a tour to get the most out of Samebug.

Tired of useless tips?

Automated exception search integrated into your IDE

Root Cause Analysis

  1. org.osgi.framework.BundleException

    Unresolved constraint in bundle CitizenRandomOsgiProjectExample [1]: Unable to resolve 1.0: missing requirement [1.0] osgi.wiring.package; (osgi.wiring.package=org.joda.convert)

    at org.apache.felix.framework.Felix.resolveBundleRevision()
  2. Apache Felix Framework
    FrameworkStartLevelImpl.run
    1. org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4097)
    2. org.apache.felix.framework.Felix.startBundle(Felix.java:2114)
    3. org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1368)
    4. org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
    4 frames
  3. Java RT
    Thread.run
    1. java.lang.Thread.run(Thread.java:745)
    1 frame