org.eclipse.aether.resolution.DependencyResolutionException

Failed to collect dependencies at io.druid.extensions:druid-kafka-eight:jar:0.8.3 -> org.apache.kafka:kafka_2.10:jar:0.8.2.1 -> org.apache.zookeeper:zookeeper:jar:3.4.6 -> jline:jline:jar:0.9.94 -> junit:junit :jar:4.11 -> org.hamcrest:hamcrest-core:jar:1.3

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web88

  • via Google Groups by Jvalant Patel, 9 months ago
    Failed to collect dependencies at io.druid.extensions:druid-kafka-eight:jar:0.8.3 -> org.apache.kafka:kafka_2.10:jar:0.8.2.1 -> org.apache.zookeeper:zookeeper:jar:3.4.6 -> jline:jline:jar:0.9.94 -> junit:junit :jar:4.11 -> org.hamcrest:hamcrest-core:jar:1.3
  • via Google Groups by Divya Sharma, 1 year ago
    Failed to collect dependencies at io.druid.extensions:druid-examples:jar:0.6.146 -> commons-validator:commons-validator:jar:1.4.0
  • via Google Groups by Xiaoming Zhang, 1 year ago
    Failed to collect dependencies at io.druid.extensions:druid-hdfs-storage:jar:0.6.153 -> net.java.dev.jets3t:jets3t:jar:0.9.1 -> org.apache.httpcomponents:httpclient:jar:4.2 -> commons-codec:commons-codec:jar:1.7
  • Stack trace

    • org.eclipse.aether.resolution.DependencyResolutionException: Failed to collect dependencies at io.druid.extensions:druid-kafka-eight:jar:0.8.3 -> org.apache.kafka:kafka_2.10:jar:0.8.2.1 -> org.apache.zookeeper:zookeeper:jar:3.4.6 -> jline:jline:jar:0.9.94 -> junit:junit :jar:4.11 -> org.hamcrest:hamcrest-core:jar:1.3 at org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveDependencies(DefaultRepositorySystem.java:380)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    You’re the first here who have seen this exception.