org.eclipse.aether.resolution.DependencyResolutionException: Failed to collect dependencies at io.druid.extensions:druid-kafka-eight:jar:0.8.3 -> org.apache.kafka:kafka_2.10:jar:0.8.2.1 -> org.apache.zookeeper:zookeeper:jar:3.4.6 -> jline:jline:jar:0.9.94 -> junit:junit :jar:4.11 -> org.hamcrest:hamcrest-core:jar:1.3

Google Groups | Jvalant Patel | 8 months ago
tip
Your exception is missing from the Samebug knowledge base.
Here are the best solutions we found on the Internet.
Click on the to mark the helpful solution and get rewards for you help.
  1. 0

    Druid 0.8.3 - How to download druid dependencies using proxy

    Google Groups | 8 months ago | Jvalant Patel
    org.eclipse.aether.resolution.DependencyResolutionException: Failed to collect dependencies at io.druid.extensions:druid-kafka-eight:jar:0.8.3 -> org.apache.kafka:kafka_2.10:jar:0.8.2.1 -> org.apache.zookeeper:zookeeper:jar:3.4.6 -> jline:jline:jar:0.9.94 -> junit:junit :jar:4.11 -> org.hamcrest:hamcrest-core:jar:1.3
  2. 0

    Compile error EnerNOC/oadr2-vtn-new

    GitHub | 4 years ago | icue11
    org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal on project oadr2-vtn-groovy: Could not resolve dependencies for project com.enernoc.open.oadr2.vtn:oadr2-vtn-groovy:grails-app:0.1-SNAPSHOT: The following artifacts could not be resolved: com.enernoc.open.oadr2:oadr2-model:jar:0.3-SNAPSHOT, com.enernoc.open.oadr2:oadr2-xmpp:jar:0.3-SNAPSHOT: Failure to find com.enernoc.open.oadr2:oadr2-model:jar:0.3-SNAPSHOT in http://repo.grails.org/grails/core was cached in the local repository, resolution will not be reattempted until the update interval of grails has elapsed or updates are forced
  3. 0

    The POM for com.bericotech:clavin-nerd:jar:2.1.0-SNAPSHOT is missing, no dependency information available

    GitHub | 2 years ago | cds-amal
    org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal on project clavin-rest: Could not resolve dependencies for project com.bericotech:clavin-rest:jar:0.3.0-SNAPSHOT: Could not find artifact com.bericotech:clavin-nerd:jar:2.1.0-SNAPSHOT
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Failure To Build Netty 4.0.25.Final

    GitHub | 2 years ago | sherman94062
    org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal on project netty-transport-native-epoll: Could not resolve dependencies for project io.netty:netty-transport-native-epoll:jar:4.1.0.Beta5-SNAPSHOT: Failure to find io.netty:netty-tcnative:jar:linux-x86_32:1.1.32.Fork1 in https://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced
  6. 0

    JBundler downloads jars, then says it can't find them

    Stack Overflow | 4 years ago | Leons
    org.eclipse.aether.resolution.DependencyResolutionException: The following artifacts could not be resolved: org.apache.j clouds.api:rackspace-cloudidentity:jar:1.6.3-20131114.121954-46, org.apache.jclouds.api:openstack-keystone:jar:1.6.3-201 31114.121702-46, org.apache.jclouds.api:openstack-cinder:jar:1.6.3-20131114.121804-46, org.apache.jclouds.api:rackspace- clouddns:jar:1.6.3-20131114.122048-46, org.apache.jclouds.provider:aws-cloudwatch:jar:1.6.3-20131114.122345-45, org.apac he.jclouds.api:cloudwatch:jar:1.6.3-20131114.121126-46, org.apache.jclouds.provider:rackspace-cloudblockstorage-us:jar:1 .6.3-20131114.123111-45, ... : Could not find artifact org.apache.jclouds.api:ra ckspace-cloudidentity:jar:1.6.3-20131114.121954-46 in central (http://repo2.maven.org/maven2)

  1. tvrmsmith 5 times, last 6 months ago
  2. davidvanlaatum 6 times, last 6 months ago
3 unregistered visitors
Not finding the right solution?
Take a tour to get the most out of Samebug.

Tired of useless tips?

Automated exception search integrated into your IDE

Root Cause Analysis

  1. org.eclipse.aether.resolution.DependencyResolutionException

    Failed to collect dependencies at io.druid.extensions:druid-kafka-eight:jar:0.8.3 -> org.apache.kafka:kafka_2.10:jar:0.8.2.1 -> org.apache.zookeeper:zookeeper:jar:3.4.6 -> jline:jline:jar:0.9.94 -> junit:junit :jar:4.11 -> org.hamcrest:hamcrest-core:jar:1.3

    at org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveDependencies()
  2. Aether Implementation
    DefaultRepositorySystem.resolveDependencies
    1. org.eclipse.aether.internal.impl.DefaultRepositorySystem.resolveDependencies(DefaultRepositorySystem.java:380)
    1 frame