org.jinterop.dcom.common.JIException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • Connect to Windows Slave (Win Server 2008)
    via by Eric Brian,
  • j-Interop - Vista and UAC
    via j-interop by markusdoering
    ,
  • "Access is denied" on localhost
    via j-interop by stalidec
    ,
  • I am trying to add a slave node to my hudson instance that will run on a Win7 VM instance on our network. If I define it to be launched by Java Web Start (and I start it using Web Start from the Win7 box), it works fine. However, if I try to start it as a Windows Service (my preferred approach), it always fails with the error ERROR: Access is denied. See http://wiki.jenkins-ci.org/display/JENKINS/Windows+slaves+fail+to+start+via+DCOM for more information about how to resolve this. org.jinterop.dcom.common.JIException: Access is denied, please check whether the [domain-username-password] are correct. Also, if not already done please check the GETTING STARTED and FAQ sections in readme.htm. They provide information on how to correctly configure the Windows machine for DCOM access, so as to avoid such exceptions. [0x00000005] at org.jinterop.dcom.core.JIComServer.init(JIComServer.java:542) at org.jinterop.dcom.core.JIComServer.initialise(JIComServer.java:458) at org.jinterop.dcom.core.JIComServer.<init>(JIComServer.java:427) at org.jvnet.hudson.wmi.WMI.connect(WMI.java:41) at hudson.os.windows.ManagedWindowsServiceLauncher.launch(ManagedWindowsServiceLauncher.java:139) at hudson.slaves.SlaveComputer$1.call(SlaveComputer.java:184) at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303) at java.util.concurrent.FutureTask.run(FutureTask.java:138) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) at java.lang.Thread.run(Thread.java:619) Caused by: rpc.FaultException: Received fault. (unknown) at rpc.ConnectionOrientedEndpoint.call(ConnectionOrientedEndpoint.java:142) at rpc.Stub.call(Stub.java:112) at org.jinterop.dcom.core.JIComServer.init(JIComServer.java:538) ... 10 more I've done everything stated in the Wiki, to no effect. I've looked at the startup and faq jinterop pages, and I've made some changes. However, I'm at the point in its instructions where I need to configure the DCOM server, and I don't know the name of the service being launched by Hudson. In our same environment, I was able to get this working on a WinXP box very quickly. I have no idea what's causing the DCOM issue for Win7. Can you please provide more information about what service I need to check, as far as permissions go? I've done everything else (I have a local user in the Administrators group, and the machine is IP reachable).
    via by hildo,
    • org.jinterop.dcom.common.JIException: Access is denied, please check whether the [domain-username-password] are correct. Also, if not already done please check the GETTING STARTED and FAQ sections in readme.htm. They provide information on how to correctly configure the Windows machine for DCOM access, so as to avoid such exceptions. [0x00000005] at org.jinterop.dcom.core.JIComServer.init(JIComServer.java:654)[org.openscada.jinterop.core_1.1.0.v20130529.jar:na] at org.jinterop.dcom.core.JIComServer.initialise(JIComServer.java:561)[org.openscada.jinterop.core_1.1.0.v20130529.jar:na] at org.jinterop.dcom.core.JIComServer.<init>(JIComServer.java:524)[org.openscada.jinterop.core_1.1.0.v20130529.jar:na] at org.openscada.opc.lib.da.Server.connect(Server.java:117)[org.openscada.opc.lib_1.1.0.v20130529.jar:na] at org.openscada.opc.tutorial.UtgardTutorial1.main(UtgardTutorial1.java:40)[bin/:na] Caused by: rpc.FaultException: Received fault. (unknown) at rpc.ConnectionOrientedEndpoint.call(ConnectionOrientedEndpoint.java:147)[org.openscada.jinterop.deps_1.1.0.v20130529.jar:na] at rpc.Stub.call(Stub.java:134)[org.openscada.jinterop.deps_1.1.0.v20130529.jar:na] at org.jinterop.dcom.core.JIComServer.init(JIComServer.java:649)[org.openscada.jinterop.core_1.1.0.v20130529.jar:na] ... 4 more

    Users with the same issue

    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,