java.lang.RuntimeException: "No solution found because the problem is unsatisfiable.": ["Unable to satisfy dependency from test.app 1.0.0.qualifier to bundle at.bestsolution.efxclipse.runtime.application 0.0.0.", "Unable to satisfy dependency from test.app 1.0.0.qualifier to bundle at.bestsolution.efxclipse.runtime.workbench.fx 0.0.0.", "Unable to satisfy dependency from test.app 1.0.0.qualifier to bundle at.bestsolution.efxclipse.runtime.theme 0.0.0.", "Unable to satisfy dependency from test.app 1.0.0.qualifier to bundle at.bestsolution.efxclipse.runtime.di 0.0.0.", "Unable to satisfy dependency from test.app 1.0.0.qualifier to bundle at.bestsolution.efxclipse.runtime.databinding 0.0.0.", "No solution found because the problem is unsatisfiable."]

Google Groups | Cosmas Chan | 4 years ago
  1. 0

    Fail to execute from deployment

    Google Groups | 4 years ago | Cosmas Chan
    java.lang.RuntimeException: "No solution found because the problem is unsatisfiable.": ["Unable to satisfy dependency from test.app 1.0.0.qualifier to bundle at.bestsolution.efxclipse.runtime.application 0.0.0.", "Unable to satisfy dependency from test.app 1.0.0.qualifier to bundle at.bestsolution.efxclipse.runtime.workbench.fx 0.0.0.", "Unable to satisfy dependency from test.app 1.0.0.qualifier to bundle at.bestsolution.efxclipse.runtime.theme 0.0.0.", "Unable to satisfy dependency from test.app 1.0.0.qualifier to bundle at.bestsolution.efxclipse.runtime.di 0.0.0.", "Unable to satisfy dependency from test.app 1.0.0.qualifier to bundle at.bestsolution.efxclipse.runtime.databinding 0.0.0.", "No solution found because the problem is unsatisfiable."]
  2. 0

    Tycho User Discussions ()

    gmane.org | 1 year ago
    java.lang.RuntimeException: "No solution found because the problem is unsatisfiable.": ["Unable to satisfy dependency from org.eclipse.jdt.core 3.8.1.v_OTDT_r210_201206090452 to org.eclipse.objectteams.otdt.core.patch.feature.group [2.0.0,3.0.0).", "Unable to satisfy dependency from org.eclipse.jdt.core 3.8.2.v_OTDT_r211_201209011847 to org.eclipse.objectteams.otdt.core.patch.feature.group [2.0.0,3.0.0).", "Unable to satisfy dependency from org.eclipse.jdt.core 3.8.3.v_OTDT_r212_201301271217 to org.eclipse.objectteams.otdt.core.patch.feature.group [2.0.0,3.0.0).", "Unable to satisfy dependency from org.openrdf.sesame2 2.7.0 to package au.com.bytecode.opencsv 0.0.0.", "No solution found because the problem is unsatisfiable."]
  3. 0

    Re: [tycho-user] Unable to satisfy dependency error

    eclipse.org | 1 year ago
    java.lang.RuntimeException: "No solution found because the problem is unsatisfiable.": ["Unable to satisfy dependency from com.iwaysoftware.transformer.feature.feature.group 1.0.0.qualifier to com.iwaysoftware.iwtrans.editor 0.0.0.", "Unable to satisfy dependency from org.eclipse.jdt.core 3.7.0.v_OTDT_r200_201106070730 to org.eclipse.objectteams.otdt.core.patch.feature.group [2.0.0,3.0.0).", "Unable to satisfy dependency from org.eclipse.jdt.core 3.7.1.v_OTDT_r201_201109101025 to org.eclipse.objectteams.otdt.core.patch.feature.group [2.0.0,3.0.0).", "Unable to satisfy dependency from org.eclipse.jdt.core 3.7.3.v_OTDT_r202_201202051448 to org.eclipse.objectteams.otdt.core.patch.feature.group [2.0.0,3.0.0).", "No solution found because the problem is unsatisfiable."]
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Scala IDE 4.0-RC1 staged (NOT YET RELEASED)

    Google Groups | 2 years ago | Iulian Dragoș
    java.lang.RuntimeException: "No solution found because the problem is unsatisfiable.": ["Unable to satisfy dependency from org.eclipse.jdt.core 3.9.0.v_OTDT_r220_201306071800 to org.eclipse.objectteams.otdt.core.patch.feature.group [2.0.0,3.0.0).", "Unable to satisfy dependency from org.eclipse.jdt.core 3.9.1.v_OTDT_r221_201309101918 to org.eclipse.objectteams.otdt.core.patch.feature.group [2.0.0,3.0.0).", "Unable to satisfy dependency from org.eclipse.jdt.core 3.9.2.v_OTDT_r222_201402180730 to org.eclipse.objectteams.otdt.core.patch.feature.group [2.0.0,3.0.0).", "Unable to satisfy dependency from org.scala-ide.sdt.core 4.0.0.rc1-2_11-201410101606-7b622ed to bundle org.eclipse.jdt.core [3.10.0,4.0.0).", "No solution found because the problem is unsatisfiable."]
  6. 0

    How to build Scala IDE master using Scala 2.10.4?

    Google Groups | 2 years ago | Jerzy Müller
    java.lang.RuntimeException: No solution found because the problem is unsatisfiable.: [Unable to satisfy dependency from org.eclipse.jdt.core 3.8.1.v_OTDT_r210_201206090452 to org.eclipse.objectteams.otdt.core.patch.feature.group [2.0.0,3.0.0).; Unable to satisfy dependency from org.eclipse.jdt.core 3.8.2.v_OTDT_r211_201209011847 to org.eclipse.objectteams.otdt.core.patch.feature.group [2.0.0,3.0.0).; Unable to satisfy dependency from org.eclipse.jdt.core 3.8.3.v_OTDT_r212_201301271217 to org.eclipse.objectteams.otdt.core.patch.feature.group [2.0.0,3.0.0).; Unable to satisfy dependency from org.scala-ide.sbt.compiler.interface 0.13.2.local-20140611-1309 to package scala.reflect.internal.tpe 0.0.0.; No solution found because the problem is unsatisfiable.]

    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. java.lang.RuntimeException

      "No solution found because the problem is unsatisfiable.": ["Unable to satisfy dependency from test.app 1.0.0.qualifier to bundle at.bestsolution.efxclipse.runtime.application 0.0.0.", "Unable to satisfy dependency from test.app 1.0.0.qualifier to bundle at.bestsolution.efxclipse.runtime.workbench.fx 0.0.0.", "Unable to satisfy dependency from test.app 1.0.0.qualifier to bundle at.bestsolution.efxclipse.runtime.theme 0.0.0.", "Unable to satisfy dependency from test.app 1.0.0.qualifier to bundle at.bestsolution.efxclipse.runtime.di 0.0.0.", "Unable to satisfy dependency from test.app 1.0.0.qualifier to bundle at.bestsolution.efxclipse.runtime.databinding 0.0.0.", "No solution found because the problem is unsatisfiable."]

      at org.eclipse.tycho.p2.resolver.AbstractResolutionStrategy.newResolutionException()
    2. org.eclipse.tycho
      P2TargetPlatformResolver.resolveDependencies
      1. org.eclipse.tycho.p2.resolver.AbstractResolutionStrategy.newResolutionException(AbstractResolutionStrategy.java:77)
      2. org.eclipse.tycho.p2.resolver.ProjectorResolutionStrategy.resolve(ProjectorResolutionStrategy.java:89)
      3. org.eclipse.tycho.p2.impl.resolver.P2ResolverImpl.resolveProject(P2ResolverImpl.java:122)
      4. org.eclipse.tycho.p2.impl.resolver.P2ResolverImpl.resolveProject(P2ResolverImpl.java:80)
      5. org.eclipse.tycho.p2.resolver.P2TargetPlatformResolver.doResolvePlatform(P2TargetPlatformResolver.java:377)
      6. org.eclipse.tycho.p2.resolver.P2TargetPlatformResolver.resolveDependencies(P2TargetPlatformResolver.java:354)
      6 frames
    3. Tycho Core (Incubation)
      TychoMavenLifecycleParticipant.afterProjectsRead
      1. org.eclipse.tycho.core.resolver.DefaultTychoDependencyResolver.resolveProject(DefaultTychoDependencyResolver.java:103)
      2. org.eclipse.tycho.core.maven.TychoMavenLifecycleParticipant.afterProjectsRead(TychoMavenLifecycleParticipant.java:82)
      2 frames
    4. Maven Core
      DefaultMaven.execute
      1. org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:274)
      2. org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
      2 frames
    5. M3 Interceptor
      MavenCli.main
      1. org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
      2. org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
      3. org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
      3 frames
    6. Java RT
      Method.invoke
      1. sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      2. sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      3. sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      4. java.lang.reflect.Method.invoke(Method.java:601)
      4 frames
    7. Plexus
      Launcher.main
      1. org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
      2. org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
      3. org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
      4. org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
      4 frames