java.net.BindException

Address already in use

Samebug tips3

Try changing the port in core-site.xml from 9000 to 9001 as it seems port 9000 doesn't work.

Change the connection port and ip adress. If you're trying to connect to your server from your own computer, check if you haven't already connected to the server in another instance.

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web4172

  • via Coderanch by shreyansh jain, 7 months ago
    Address already in use
  • via Coderanch by Jacksy Verghese, 8 months ago
    Address already in use
  • via Coderanch by Danish Shaukat, 7 months ago
    Address already in use
  • Stack trace

    • java.net.BindException: Address already in use at sun.nio.ch.Net.bind0(Native Method) at sun.nio.ch.Net.bind(Unknown Source) at sun.nio.ch.Net.bind(Unknown Source) at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source) at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source) at org.eclipse.jetty.server.nio.SelectChannelConnector.open(SelectChannelConnector.java:187) at org.eclipse.jetty.server.AbstractConnector.doStart(AbstractConnector.java:316) at org.eclipse.jetty.server.nio.SelectChannelConnector.doStart(SelectChannelConnector.java:265) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:64) at org.eclipse.jetty.server.Server.doStart(Server.java:293) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:64) at com.sonian.elasticsearch.http.jetty.JettyHttpServerTransport$1.onPortNumber(JettyHttpServerTransport.java:157) at org.elasticsearch.common.transport.PortsRange.iterate(PortsRange.java:69) at com.sonian.elasticsearch.http.jetty.JettyHttpServerTransport.doStart(JettyHttpServerTransport.java:100) at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:85) at org.elasticsearch.http.HttpServer.doStart(HttpServer.java:89) at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:85) at org.elasticsearch.node.internal.InternalNode.start(InternalNode.java:250) at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:122) at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:206) at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:32)[2014-09-24 14:17:04,350]

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Once, 3 months ago
    36 times, 3 months ago
    3 times, 7 months ago
    6 times, 11 months ago
    Unknown user
    Once, 1 year ago
    143 more bugmates