io.fabric8.kubernetes.client.KubernetesClientException

An error has occurred.


Solutions on the web83

Solution icon of github
via GitHub by tajdars
, 4 months ago
An error has occurred.

Solution icon of github
via GitHub by BoriszhangSec
, 11 months ago
An error has occurred.

Solution icon of github
via GitHub by BoriszhangSec
, 10 months ago
An error has occurred.

Solution icon of github
via GitHub by jstrachan
, 1 year ago
An error has occurred.

Solution icon of github
An error has occurred.

Solution icon of github
An error has occurred.

Solution icon of github
An error has occurred.

Solution icon of github
via GitHub by ntrvic
, 11 months ago
An error has occurred.

Solution icon of github
An error has occurred.

Solution icon of github
An error has occurred.

Stack trace

  • io.fabric8.kubernetes.client.KubernetesClientException: An error has occurred. at io.fabric8.kubernetes.client.KubernetesClientException.launderThrowable(KubernetesClientException.java:57) at io.fabric8.kubernetes.client.dsl.base.BaseOperation.create(BaseOperation.java:234) at com.aruba.test.test_app.main(test_app.java:117) Caused by: javax.net.ssl.SSLPeerUnverifiedException: Hostname kubernetes.default.svc not verified:* * certificate: sha1/pn3xC0EodJTjGo5zetEr8QSgnyo=* *DN: CN=kube-apiserver* subjectAltNames: [10.3.0.1, 10.22.42.243, kubernetes, kubernetes.default] could you please help me out to resolve this? On Fri, May 13, 2016 at 8:56 PM, James Strachan <james.s...@gmail.com> wrote: On 12 May 2016 at 11:14, Pradeep Ganachari <ganachar...@gmail.com> wrote: Hello, I am trying to create Kubernetes Job using following code. *client.extensions().jobs().inNamespace("aa-system").create(job);* with all necessary data filled in job. Getting following exception. FAILED: *java.lang.IllegalStateException: No adapter available for type:class io.fabric8.kubernetes.client.ExtensionsAPIGroupClient* java.lang.IllegalStateException: No adapter available for type:class io.fabric8.kubernetes.client.ExtensionsAPIGroupClient at io.fabric8.kubernetes.client.BaseClient.adapt(BaseClient.java:135) at io.fabric8.kubernetes.client.DefaultKubernetesClient.extensions(DefaultKubernetesClient.java:214)

Write tip

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

Users with the same issue

You are the first who have seen this exception. Write a tip to help other users and build your expert profile.