org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.wrap [29]: Unable to resolve 29.0: missing requirement [29.0] package; (&(package=org.apache.felix.fileinstall)(version>=3.2.0)(!(version>=4.0.0))) [caused by: Unable to resolve 6.0: missing requirement [6.0] package; (&(package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))] ERROR: Bundle org.apache.karaf.deployer.wrap [29] Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.wrap/2.2.11 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.wrap [29]: Unable to resolve 29.0: missing requirement [29.0] package; (&(package=org.apache.felix.fileinstall)(version>=3.2.0)(!(version>=4.0.0))) [caused by: Unable to resolve 6.0: missing requirement [6.0] package; (&(package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))])

GitHub | aowen | 2 years ago
  1. 0

    GitHub comment 1#96446737

    GitHub | 2 years ago | aowen
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.wrap [29]: Unable to resolve 29.0: missing requirement [29.0] package; (&(package=org.apache.felix.fileinstall)(version>=3.2.0)(!(version>=4.0.0))) [caused by: Unable to resolve 6.0: missing requirement [6.0] package; (&(package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))] ERROR: Bundle org.apache.karaf.deployer.wrap [29] Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.wrap/2.2.11 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.wrap [29]: Unable to resolve 29.0: missing requirement [29.0] package; (&(package=org.apache.felix.fileinstall)(version>=3.2.0)(!(version>=4.0.0))) [caused by: Unable to resolve 6.0: missing requirement [6.0] package; (&(package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))])
  2. 0

    Cannot run Spring Roo shell - "Unable to resolve .. missing requirement .. package=javax.xml..."

    Stack Overflow | 2 years ago | Lucas
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.antlr4-runtime [74]: Unable to resolve 74.0: missing requirement [74.0] package; (package=javax.imageio)
  3. 0

    GitHub comment 1#96436594

    GitHub | 2 years ago | rchawdry
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.kar [36]: Unable to resolve 36.0: missing requirement [36.0] package; (package=javax.xml.parsers)
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Ubuntu14.04+Java8でSpring ROO のエラーが出る - Qiita

    qiita.com | 4 months ago
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.uaa.client [81]: Unable to resolve 81.0: missing requirement [81.0] package; (package=javax.xml.parsers)
  6. 0

    Resolve dependencies error in Sling OSGi container

    Stack Overflow | 2 years ago | Barcelona
    org.osgi.framework.BundleException: Unresolved constraint in bundle net.jasonday.examples.sling.spring.mvc [79]: Unable to resolve 79.0: missing requirement [79 .0] package; (&(package=javax.annotation)(version>=1.0.0)(!(version>=2.0.0)))

    3 unregistered visitors
    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. org.osgi.framework.BundleException

      Unresolved constraint in bundle org.apache.karaf.deployer.wrap [29]: Unable to resolve 29.0: missing requirement [29.0] package; (&(package=org.apache.felix.fileinstall)(version>=3.2.0)(!(version>=4.0.0))) [caused by: Unable to resolve 6.0: missing requirement [6.0] package; (&(package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))] ERROR: Bundle org.apache.karaf.deployer.wrap [29] Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.wrap/2.2.11 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.wrap [29]: Unable to resolve 29.0: missing requirement [29.0] package; (&(package=org.apache.felix.fileinstall)(version>=3.2.0)(!(version>=4.0.0))) [caused by: Unable to resolve 6.0: missing requirement [6.0] package; (&(package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))])

      at org.apache.felix.framework.Felix.resolveBundle()
    2. Apache Felix Framework
      StartLevelImpl.run
      1. org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
      2. org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
      3. org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
      4. org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
      4 frames
    3. Java RT
      Thread.run
      1. java.lang.Thread.run(Thread.java:745)
      1 frame