java.lang.AssertionError

Wrong all sources jars expected:<List(C:/Program Files/Eclipse/luna/plugins/org.scala-lang.scala-actors.source_2.11.2.v20140721-095018-73fb460c1c.jar, C:/Program Files/Eclipse/luna/plugins/org.scala-lang.scala-compiler.source_2.11.2.v20140721-095018-73fb460c1c.jar, C:/Program Files/Eclipse/luna/plugins/org.scala-lang.scala-library.source_2.11.2.v20140721-095018-73fb460c1c.jar, C:/Program Files/Eclipse/luna/plugins/org.scala-lang.scala-reflect.source_2.11.2.v20140721-095018-73fb460c1c.jar)> but was:<List()>

Samebug tips1

Check your pattern declaration or check your assert declaration.

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web5988

  • via Google Groups by Matthias Langer, 1 year ago
    Wrong all sources jars expected:<List(C:/Program Files/Eclipse/luna/plugins/org.scala-lang.scala-actors.source_2.11.2.v20140721-095018-73fb460c1c.jar, C:/Program Files/Eclipse/luna/plugins/org.scala-lang.scala-compiler.source_2.11.2.v20140721
  • via Stack Overflow by Joe Schleiptner
    , 8 months ago
    -agent.jar;C:\Program Files\Java\jdk1.8.0_102\jre\lib\plugin.jar;C:\Program Files\Java\jdk1.8.0_102\jre\lib\resources.jar;C:\Program Files\Java\jdk1.8.0_102\jre\lib\rt.jar;D:\temp\scala\scalatest3\target\scala-2.12\classes;D:\Bin\.ivy2\cache\org.scala-lang
  • via Google Groups by Stefan Zeiger, 1 year ago
    version: version 2.10.0-20120425-140228-8f3f0724f9 reconstructed args: -deprecation -d C:\Users\szeiger\code\scala-query\target\scala-2.10\classes -bootclasspath C:\Program Files\Java\jre6\lib\resources.jar;C:\Program Files\Java\jre6\lib\rt.jar;C
  • Stack trace

    • java.lang.AssertionError: Wrong all sources jars expected:<List(C:/Program Files/Eclipse/luna/plugins/org.scala-lang.scala-actors.source_2.11.2.v20140721-095018-73fb460c1c.jar, C:/Program Files/Eclipse/luna/plugins/org.scala-lang.scala-compiler.source_2.11.2.v20140721-095018-73fb460c1c.jar, C:/Program Files/Eclipse/luna/plugins/org.scala-lang.scala-library.source_2.11.2.v20140721-095018-73fb460c1c.jar, C:/Program Files/Eclipse/luna/plugins/org.scala-lang.scala-reflect.source_2.11.2.v20140721-095018-73fb460c1c.jar)> but was:<List()> at org.junit.Assert.fail(Assert.java:88) at org.junit.Assert.failNotEquals(Assert.java:743) at org.junit.Assert.assertEquals(Assert.java:118) at org.scalaide.core.project.ScalaInstallationTest.checkMultiBundleInstallation(ScalaInstallationTest.scala:137) at org.scalaide.core.project.ScalaInstallationTest.multiBundleInstallationsTest(ScalaInstallationTest.scala:81)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    3 times, 1 week ago
    Once, 2 months ago
    2 times, 2 days ago
    Once, 1 week ago
    4 times, 1 week ago
    98 more bugmates