org.osgi.framework.BundleException

Could not resolve module: org.compiere.db.postgresql.provider [8] Unresolved requirement: Require-Bundle: org.adempiere.base; bundle-version="0.0.0" -> Bundle-SymbolicName: org.adempiere.base; bundle-version="3.1.0.v20160908-0228"; singleton:="true" org.adempiere.base [6] Unresolved requirement: Import-Package: org.apache.ecs -> Export-Package: org.apache.ecs; bundle-version="3.1.0.v20160908-0228"; bundle-symbolic-name="org.apache.ecs"; version="0.0.0"; uses:="org.apache.ecs.xhtml" org.apache.ecs [18] Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.8))"

Solutions on the web6488

  • via Google Groups by Jerry Duenas, 9 months ago
    Could not resolve module: org.compiere.db.postgresql.provider [8] Unresolved requirement: Require-Bundle: org.adempiere.base; bundle-version="0.0.0" -> Bundle-SymbolicName: org.adempiere.base; bundle-version="3.1.0.v20160908-0228
  • via Google Groups by gopei Leonard, 4 weeks ago
    "; singleton:="true" org.adempiere.base [6] Unresolved requirement: Import-Package: org.apache.ecs -> Export-Package: org.apache.ecs; bundle-version="3.1.0.v20151031-2002"; bundle-symbolic-name="org.apache.ecs"; version="0.0.0
  • via Google Groups by Andrea Checchia, 1 year ago
    "; singleton:="true" org.adempiere.base [6] Unresolved requirement: Import-Package: org.apache.ecs -> Export-Package: org.apache.ecs; bundle-version= "3.0.0.v20150921-0231"; bundle-symbolic-name="org.apache.ecs"; version= "0.0.0
  • Stack trace

    • org.osgi.framework.BundleException: Could not resolve module: org.compiere.db.postgresql.provider [8] Unresolved requirement: Require-Bundle: org.adempiere.base; bundle-version="0.0.0" -> Bundle-SymbolicName: org.adempiere.base; bundle-version="3.1.0.v20160908-0228"; singleton:="true" org.adempiere.base [6] Unresolved requirement: Import-Package: org.apache.ecs -> Export-Package: org.apache.ecs; bundle-version="3.1.0.v20160908-0228"; bundle-symbolic-name="org.apache.ecs"; version="0.0.0"; uses:="org.apache.ecs.xhtml" org.apache.ecs [18] Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.8))" at org.eclipse.osgi.container.Module.start(Module.java:434) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476) at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1) at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230) at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 10 months ago
    Unknown user
    Once, 11 months ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    43 more bugmates