java.lang.UnsupportedClassVersionError

nz/co/fortytwo/signalk/server/SignalKServer : Unsupported major.minor version 52.0

Samebug tips4

Update "latest" to Java 8 on DockerHub.

You're using an older version of java with classes compiled for java7

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web4802

  • via GitHub by ph1l
    , 8 months ago
    nz/co/fortytwo/signalk/server/SignalKServer : Unsupported major.minor version 52.0
  • via GitHub by ph1l
    , 9 months ago
    nz/co/fortytwo/signalk/server/SignalKServer : Unsupported major.minor version 52.0
  • nz/co/fortytwo/signalk/server/SignalKServer : Unsupported major.minor version 52.0
  • Stack trace

    • java.lang.UnsupportedClassVersionError: nz/co/fortytwo/signalk/server/SignalKServer : Unsupported major.minor version 52.0 at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:803) at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) at java.net.URLClassLoader.defineClass(URLClassLoader.java:449) at java.net.URLClassLoader.access$100(URLClassLoader.java:71) at java.net.URLClassLoader$1.run(URLClassLoader.java:361) at java.net.URLClassLoader$1.run(URLClassLoader.java:355) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:354) at java.lang.ClassLoader.loadClass(ClassLoader.java:425) at java.lang.ClassLoader.loadClass(ClassLoader.java:358) at org.codehaus.mojo.exec.ExecJavaMojo$1.run(ExecJavaMojo.java:281) at java.lang.Thread.run(Thread.java:745)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 6 months ago
    Once, 1 month ago
    Unknown user
    Once, 3 months ago
    2 times, 3 months ago
    Once, 7 months ago
    194 more bugmates