org.eclipse.core.runtime.CoreException: Plug-in com.subgraph.vega.application was unable to load class com.subgraph.vega.application.Application.

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

,
via Stack Overflow by ERJAN

This exception occurs when using an older version of java. Mainly when trying to run a jar compiled with a newer Java version in an older Java version. We can avoid this issue by executing the jar in the same version which it was compiled.

,
via Google Groups by Marcus Haebler

Update "latest" to Java 8 on DockerHub.

Solutions on the web

via Google Groups by preetam pujar, 5 months ago
Plug-in com.subgraph.vega.application was unable to load class com.subgraph.vega.application.Application.
via GitHub by SinisterShade
, 1 year ago
Plug-in com.subgraph.vega.application was unable to load class com.subgraph.vega.application.Application.
via GitHub by deijmaster
, 2 years ago
Plug-in com.subgraph.vega.application was unable to load class com.subgraph.vega.application.Application.
via GitHub by nemoDreamer
, 2 years ago
Plug-in com.subgraph.vega.application was unable to load class com.subgraph.vega.application.Application.
via Google Groups by Stu Beans, 1 year ago
Plug-in com.subgraph.vega.application was unable to load class com.subgraph.vega.application.Application.
via GitHub by jbajou
, 2 years ago
Plug-in com.subgraph.vega.application was unable to load class com.subgraph.vega.application.Application.
org.eclipse.core.runtime.CoreException: Plug-in com.subgraph.vega.application was unable to load class com.subgraph.vega.application.Application.
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.defineClass(DefaultClassLoader.java:188)
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.defineClassHoldingLock(ClasspathManager.java:632)
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.defineClass(ClasspathManager.java:614)
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findClassImpl(ClasspathManager.java:568)
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClassImpl(ClasspathManager.java:492)
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:465)
at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:395)
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:464)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:421)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
at org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(BundleHost.java:229)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Once, 1 week ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
338 more bugmates

Know the solutions? Share your knowledge to help other developers to debug faster.