org.osgi.framework.BundleException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • Unable to start Spring Roo and get it working
    via by Unknown author,
  • Custom Spring roo addon fail
    via Stack Overflow by user2378554
    ,
  • NoClassDefFoundError when loading BundleContext
    via by René Groeschke,
    • org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.configurable [8]: Unable to resolve 8.0: missing requirement [8.0] package; (&(package=org.springframework.roo.classpath)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 36.0: missing requirement [36.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 39.0: missing requirement [39.0] package; (&(package=org.springframework.roo.support.ant)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 52.0: missing requirement [52.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409) at org.apache.felix.framework.Felix.startBundle(Felix.java:1719) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1148) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264) at java.lang.Thread.run(Unknown Source)

    Users with the same issue

    andyglick
    2 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    2 more bugmates