java.lang.UnsupportedClassVersionError: org/webjars/WebJarExtractor$Cache : Unsupported major.minor version 51.0

  1. 0

    Java config for Lightbend Activator

    Ask Ubuntu | 6 months ago | Christopher Brinkley
    java.lang.UnsupportedClassVersionError: org/webjars/WebJarExtractor$Cache : Unsupported major.minor version 51.0
  2. 0

    Failed to load sbt config on Ubuntu when it worked on Windows

    GitHub | 6 months ago | brinklec
    java.lang.UnsupportedClassVersionError: org/webjars/WebJarExtractor$Cache : Unsupported major.minor version 51.0 ``` In the "activator run" case, there is a long error stack that begins and ends like this: ```
  3. 0

    Lightbend Activator failed to load sbt configuration on Ubuntu that works on Windows

    Stack Overflow | 6 months ago | Christopher Brinkley
    java.lang.UnsupportedClassVersionError: org/webjars/WebJarExtractor$Cache : Unsupported major.minor version 51.0 "activator run" further yields: at java.lang.Classloader.defineClass1(Native Method) ...
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0
    This seems to be caused by an outdated version of Java, since SonarQube now uses Java 8 as default. You might upgrade java or use an older version of SonarQube
  6. 0
    You're using an older version of java with classes compiled for java7
    via GitHub by Athou

    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. java.lang.UnsupportedClassVersionError

      org/webjars/WebJarExtractor$Cache : Unsupported major.minor version 51.0

      at java.lang.Classloader.defineClass1()
    2. Java RT
      Classloader.defineClass1
      1. java.lang.Classloader.defineClass1(Native Method)
      1 frame