java.lang.UnsatisfiedLinkError

C:\Users\Neil\.edpan\hoepli\picchi\org.eclipse.osgi\bundles\39\1\.cp\swt-win32-3139.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform

Samebug tips1

This happens sometimes when Android fails to load the necessary libraries when you install an app. Try reinstalling it or telling your client to reinstall it, as it seems to correctly install the libraries and fixes the problem.

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web3838

  • C:\Users\Neil\.edpan\hoepli\picchi\org.eclipse.osgi\bundles\39\1\.cp\swt-win32-3139.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform
  • via hivmr.com by Unknown author, 11 months ago
    C:\OracleBI_101340\web\catalogmanager\configuration\org.eclipse.osgi\bundles\8\1\.cp\swt-win32-3138.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform
  • via Oracle Community by 724120, 11 months ago
    C:\OracleBI_101340\web\catalogmanager\configuration\org.eclipse.osgi\bundles\8\1\.cp\swt-win32-3138.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform
  • Stack trace

    • java.lang.UnsatisfiedLinkError: C:\Users\Neil\.edpan\hoepli\picchi\org.eclipse.osgi\bundles\39\1\.cp\swt-win32-3139.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform at java.lang.ClassLoader$NativeLibrary.load(Native Method) at java.lang.ClassLoader.loadLibrary1(ClassLoader.java:1939) at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1864) at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1838) at java.lang.Runtime.loadLibrary0(Runtime.java:845) at java.lang.System.loadLibrary(System.java:1084) at org.eclipse.swt.internal.Library.loadLibrary(Library.java:123) at org.eclipse.swt.internal.win32.OS.<clinit>(OS.java:18) at org.eclipse.swt.widgets.Display.<clinit>(Display.java:125) at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:381) at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:155) at edPan.ui.application.Application.run(Application.java:18) at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:226) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:376) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:163) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:601) at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334) at org.eclipse.core.launcher.Main.basicRun(Main.java:278) at org.eclipse.core.launcher.Main.run(Main.java:973) at org.eclipse.core.launcher.Main.main(Main.java:948) at org.eclipse.core.launcher.Main2.main(Main2.java:46)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 11 months ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    298 more bugmates