java.lang.IllegalArgumentException: You need to use a Theme.AppCompat theme (or descendant) with the design library.

Stack Overflow | s.g | 2 months ago
  1. 0

    Exception Details java.lang.IllegalArgumentException: You need to use a Theme.AppCompat theme (or descendant) with the design library

    Stack Overflow | 2 months ago | s.g
    java.lang.IllegalArgumentException: You need to use a Theme.AppCompat theme (or descendant) with the design library.
  2. 0

    Getting rid of the title bar when using android.support.design.widget.CoordinatorLayout without affecting rendering of sample layouts

    Stack Overflow | 1 year ago | safe_malloc
    java.lang.IllegalArgumentException: You need to use a Theme.AppCompat theme (or descendant) with the design library.
  3. 0

    Ubuntu 14.04 -Android Studio: The following classes could not be instantiated

    Stack Overflow | 1 year ago | Alkarin
    java.lang.IllegalArgumentException: You need to use a Theme.AppCompat theme (or descendant) with the design library.
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Rendering issue occur running an android app in Android Studio

    Stack Overflow | 11 months ago | Rishi Kesh
    java.lang.IllegalArgumentException: You need to use a Theme.AppCompat theme (or descendant) with the design library.
  6. 0

    Switching to Material Light Theme yeilds error - thenewboston Forum

    thenewboston.com | 11 months ago
    java.lang.IllegalArgumentException: You need to use a Theme.AppCompat theme (or descendant) with the design library.

  1. dmitry 1 times, last 8 months ago
  2. balajivaishnav 1 times, last 9 months ago
22 unregistered visitors
Not finding the right solution?
Take a tour to get the most out of Samebug.

Tired of useless tips?

Automated exception search integrated into your IDE

Root Cause Analysis

  1. java.lang.IllegalArgumentException

    You need to use a Theme.AppCompat theme (or descendant) with the design library.

    at android.support.design.widget.ThemeUtils.checkAppCompatTheme()
  2. android.support.design
    CoordinatorLayout.<init>
    1. android.support.design.widget.ThemeUtils.checkAppCompatTheme(ThemeUtils.java:34)
    2. android.support.design.widget.CoordinatorLayout.<init>(CoordinatorLayout.java:184)
    3. android.support.design.widget.CoordinatorLayout.<init>(CoordinatorLayout.java:178)
    3 frames
  3. Java RT
    Constructor.newInstance
    1. java.lang.reflect.Constructor.newInstance(Constructor.java:422)
    1 frame
  4. Android Platform
    LayoutInflater.inflate
    1. android.view.LayoutInflater.createViewFromTag(LayoutInflater.java:704)
    2. android.view.LayoutInflater.inflate(LayoutInflater.java:492)
    3. android.view.LayoutInflater.inflate(LayoutInflater.java:394)
    3 frames