org.osgi.framework.BundleException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • I constantly have this set of errors while creating a Fabric {code} 2014-09-17 12:30:48,104 | ERROR | agent-1-thread-1 | DeploymentAgent | 81 - io.fabric8.fabric-agent - 1.2.0.SNAPSHOT | Unable to update agent io.fabric8.common.util.MultiException: Error updating agent at io.fabric8.agent.DeploymentAgent.install(DeploymentAgent.java:988)[81:io.fabric8.fabric-agent:1.2.0.SNAPSHOT] at io.fabric8.agent.DeploymentAgent.doUpdate(DeploymentAgent.java:593)[81:io.fabric8.fabric-agent:1.2.0.SNAPSHOT] at io.fabric8.agent.DeploymentAgent$2.run(DeploymentAgent.java:313)[81:io.fabric8.fabric-agent:1.2.0.SNAPSHOT] at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)[:1.7.0_65] at java.util.concurrent.FutureTask.run(FutureTask.java:262)[:1.7.0_65] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)[:1.7.0_65] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)[:1.7.0_65] at java.lang.Thread.run(Thread.java:745)[:1.7.0_65] Caused by: org.osgi.framework.BundleException: Uses constraint violation. Unable to resolve bundle revision org.apache.servicemix.bundles.spring-context-support [177.0] because it is exposed to package 'org.apache.commons.logging' from bundle revisions org.ops4j.pax.logging.pax-logging-api [4.0] and org.ops4j.pax.swissbox.optional.jcl [162.0] via two dependency chains. Chain 1: org.apache.servicemix.bundles.spring-context-support [177.0] import: (&(osgi.wiring.package=org.apache.commons.logging)(version>=1.1.1)(!(version>=2.0.0))) | export: osgi.wiring.package=org.apache.commons.logging org.ops4j.pax.logging.pax-logging-api [4.0] Chain 2: org.apache.servicemix.bundles.spring-context-support [177.0] import: (&(osgi.wiring.package=org.apache.velocity.context)(version>=1.5.0)(!(version>=2.0.0))) | export: osgi.wiring.package=org.apache.velocity.context; uses:=org.apache.commons.logging org.apache.servicemix.bundles.velocity [188.0] import: (&(osgi.wiring.package=org.apache.commons.logging)(version>=1.1.0)(!(version>=2.0.0))) | export: osgi.wiring.package=org.apache.commons.logging org.ops4j.pax.swissbox.optional.jcl [162.0] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4006)[org.apache.felix.framework-4.4.1.jar:] at org.apache.felix.framework.Felix.startBundle(Felix.java:2045)[org.apache.felix.framework-4.4.1.jar:] at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:976)[org.apache.felix.framework-4.4.1.jar:] at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:963)[org.apache.felix.framework-4.4.1.jar:] at io.fabric8.agent.DeploymentAgent.install(DeploymentAgent.java:981)[81:io.fabric8.fabric-agent:1.2.0.SNAPSHOT] ... 7 more 2014-09-17 12:30:50,397 | INFO | pool-49-thread-1 | ActiveMQServiceFactory | 202 - io.fabric8.mq.mq-fabric - 1.2.0.SNAPSHOT | booting up a broker from: profile:broker.xml 2014-09-17 12:30:50,398 | INFO | pool-49-thread-1 | ActiveMQServiceFactory$1 | 176 - org.apache.servicemix.bundles.spring-context - 3.2.9.RELEASE_1 | Refreshing io.fabric8.mq.fabric.ActiveMQServiceFactory$1@4a3b90a: startup date [Wed Sep 17 12:30:50 CEST 2014]; root of context hierarchy 2014-09-17 12:30:50,399 | INFO | pool-49-thread-1 | XBeanXmlBeanDefinitionReader | 174 - org.apache.servicemix.bundles.spring-beans - 3.2.9.RELEASE_1 | Loading XML bean definitions from URL [profile:broker.xml] 2014-09-17 12:30:50,410 | INFO | pool-49-thread-1 | ActiveMQServiceFactory | 202 - io.fabric8.mq.mq-fabric - 1.2.0.SNAPSHOT | Broker root failed to start. Will try again in 10 seconds 2014-09-17 12:30:50,411 | ERROR | pool-49-thread-1 | ActiveMQServiceFactory | 202 - io.fabric8.mq.mq-fabric - 1.2.0.SNAPSHOT | Exception on start: Unexpected exception parsing XML document from URL [profile:broker.xml]; nested exception is org.apache.xerces.parsers.ObjectFactory$ConfigurationError: Provider org.apache.xerces.parsers.XIncludeAwareParserConfiguration could not be instantiated: org.apache.xerces.impl.dv.DVFactoryException: DTD factory class org.apache.xerces.impl.dv.dtd.DTDDVFactoryImpl does not extend from DTDDVFactory. org.springframework.beans.factory.BeanDefinitionStoreException: Unexpected exception parsing XML document from URL [profile:broker.xml]; nested exception is org.apache.xerces.parsers.ObjectFactory$ConfigurationError: Provider org.apache.xerces.parsers.XIncludeAwareParserConfiguration could not be instantiated: org.apache.xerces.impl.dv.DVFactoryException: DTD factory class org.apache.xerces.impl.dv.dtd.DTDDVFactoryImpl does not extend from DTDDVFactory. at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadBeanDefinitions(XmlBeanDefinitionReader.java:412)[174:org.apache.servicemix.bundles.spring-beans:3.2.9.RELEASE_1] at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:334)[174:org.apache.servicemix.bundles.spring-beans:3.2.9.RELEASE_1] at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.loadBeanDefinitions(XmlBeanDefinitionReader.java:302)[174:org.apache.servicemix.bundles.spring-beans:3.2.9.RELEASE_1] at org.apache.xbean.spring.context.ResourceXmlApplicationContext.loadBeanDefinitions(ResourceXmlApplicationContext.java:111)[184:org.apache.xbean.spring:3.16.0] at org.apache.xbean.spring.context.ResourceXmlApplicationContext.loadBeanDefinitions(ResourceXmlApplicationContext.java:104)[184:org.apache.xbean.spring:3.16.0] at org.springframework.context.support.AbstractRefreshableApplicationContext.refreshBeanFactory(AbstractRefreshableApplicationContext.java:130)[176:org.apache.servicemix.bundles.spring-context:3.2.9.RELEASE_1] at org.springframework.context.support.AbstractApplicationContext.obtainFreshBeanFactory(AbstractApplicationContext.java:537)[176:org.apache.servicemix.bundles.spring-context:3.2.9.RELEASE_1] at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:451)[176:org.apache.servicemix.bundles.spring-context:3.2.9.RELEASE_1] at org.apache.xbean.spring.context.ResourceXmlApplicationContext.<init>(ResourceXmlApplicationContext.java:64)[184:org.apache.xbean.spring:3.16.0] at org.apache.xbean.spring.context.ResourceXmlApplicationContext.<init>(ResourceXmlApplicationContext.java:52)[184:org.apache.xbean.spring:3.16.0] at io.fabric8.mq.fabric.ActiveMQServiceFactory$1.<init>(ActiveMQServiceFactory.java:196)[202:io.fabric8.mq.mq-fabric:1.2.0.SNAPSHOT] at io.fabric8.mq.fabric.ActiveMQServiceFactory.createBroker(ActiveMQServiceFactory.java:196)[202:io.fabric8.mq.mq-fabric:1.2.0.SNAPSHOT] at io.fabric8.mq.fabric.ActiveMQServiceFactory$ClusteredConfiguration.doStart(ActiveMQServiceFactory.java:588)[202:io.fabric8.mq.mq-fabric:1.2.0.SNAPSHOT] at io.fabric8.mq.fabric.ActiveMQServiceFactory$ClusteredConfiguration.access$700(ActiveMQServiceFactory.java:412)[202:io.fabric8.mq.mq-fabric:1.2.0.SNAPSHOT] at io.fabric8.mq.fabric.ActiveMQServiceFactory$ClusteredConfiguration$1.run(ActiveMQServiceFactory.java:543)[202:io.fabric8.mq.mq-fabric:1.2.0.SNAPSHOT] at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)[:1.7.0_65] at java.util.concurrent.FutureTask.run(FutureTask.java:262)[:1.7.0_65] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)[:1.7.0_65] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)[:1.7.0_65] at java.lang.Thread.run(Thread.java:745)[:1.7.0_65] Caused by: org.apache.xerces.parsers.ObjectFactory$ConfigurationError: Provider org.apache.xerces.parsers.XIncludeAwareParserConfiguration could not be instantiated: org.apache.xerces.impl.dv.DVFactoryException: DTD factory class org.apache.xerces.impl.dv.dtd.DTDDVFactoryImpl does not extend from DTDDVFactory. at org.apache.xerces.parsers.ObjectFactory.newInstance(Unknown Source)[:] at org.apache.xerces.parsers.ObjectFactory.createObject(Unknown Source)[:] at org.apache.xerces.parsers.ObjectFactory.createObject(Unknown Source)[:] at org.apache.xerces.parsers.DOMParser.<init>(Unknown Source)[:] at org.apache.xerces.parsers.DOMParser.<init>(Unknown Source)[:] at org.apache.xerces.jaxp.DocumentBuilderImpl.<init>(Unknown Source)[:] at org.apache.xerces.jaxp.DocumentBuilderFactoryImpl.newDocumentBuilder(Unknown Source)[:] at org.springframework.beans.factory.xml.DefaultDocumentLoader.createDocumentBuilder(DefaultDocumentLoader.java:130)[174:org.apache.servicemix.bundles.spring-beans:3.2.9.RELEASE_1] at org.springframework.beans.factory.xml.DefaultDocumentLoader.loadDocument(DefaultDocumentLoader.java:74)[174:org.apache.servicemix.bundles.spring-beans:3.2.9.RELEASE_1] at org.springframework.beans.factory.xml.XmlBeanDefinitionReader.doLoadBeanDefinitions(XmlBeanDefinitionReader.java:388)[174:org.apache.servicemix.bundles.spring-beans:3.2.9.RELEASE_1] ... 19 more {code} {code} 12:32:30 (...0.redhat-SNAPSHOT)$ java -version java version "1.7.0_65" OpenJDK Runtime Environment (fedora-2.5.2.5.fc20-x86_64 u65-b17) OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode {code}
    via by Paolo Antinori,
  • [protege-user] Initialization Problem
    via by Unknown author,
  • Error when starting protege
    via GitHub by magick93
    ,
  • Was trying to follow the example osgi in the repo, but my bundle fails with following message: {code:java} .................. .................. .................. -> Runner has successfully finished his job! -> Waiting for framework exit. ERROR: Bundle caao-osgi-bundle [4] Error starting file:bundles/caao-osgi-bundle_1.0.0.SNAPSHOT.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle caao-osgi-bundle [4]: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=com.codahale.metrics)(version>=3.0.0)(!(version>=4.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.6.0)(!(version>=2.0.0))) [caused by: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))]]) org.osgi.framework.BundleException: Unresolved constraint in bundle caao-osgi-bundle [4]: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=com.codahale.metrics)(version>=3.0.0)(!(version>=4.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.6.0)(!(version>=2.0.0))) [caused by: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))]] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002) at org.apache.felix.framework.Felix.startBundle(Felix.java:2045) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304) at java.lang.Thread.run(Thread.java:745) ERROR: Bundle slf4j.api [10] Error starting file:bundles/slf4j.api_1.6.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle slf4j.api [10]: Unable to resolve 10.0: missing requirement [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.5.5))) org.osgi.framework.BundleException: Unresolved constraint in bundle slf4j.api [10]: Unable to resolve 10.0: missing requirement [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.5.5)) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002) at org.apache.felix.framework.Felix.startBundle(Felix.java:2045) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304) at java.lang.Thread.run(Thread.java:745) ERROR: Bundle com.datastax.driver.core [15] Error starting file:bundles/com.datastax.driver.core_2.2.0.rc2.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle com.datastax.driver.core [15]: Unable to resolve 15.0: missing requirement [15.0] osgi.wiring.package; (&(osgi.wiring.package=com.codahale.metrics)(version>=3.0.0)(!(version>=4.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.6.0)(!(version>=2.0.0))) [caused by: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))]]) org.osgi.framework.BundleException: Unresolved constraint in bundle com.datastax.driver.core [15]: Unable to resolve 15.0: missing requirement [15.0] osgi.wiring.package; (&(osgi.wiring.package=com.codahale.metrics)(version>=3.0.0)(!(version>=4.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.6.0)(!(version>=2.0.0))) [caused by: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))]] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002) at org.apache.felix.framework.Felix.startBundle(Felix.java:2045) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304) at java.lang.Thread.run(Thread.java:745) ERROR: Bundle com.codahale.metrics.core [22] Error starting file:bundles/com.codahale.metrics.core_3.0.2.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle com.codahale.metrics.core [22]: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.6.0)(!(version>=2.0.0))) [caused by: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))]) org.osgi.framework.BundleException: Unresolved constraint in bundle com.codahale.metrics.core [22]: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.6.0)(!(version>=2.0.0))) [caused by: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002) at org.apache.felix.framework.Felix.startBundle(Felix.java:2045) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304) at java.lang.Thread.run(Thread.java:745) ERROR: Bundle slf4j.api [23] Error starting file:bundles/slf4j.api_1.7.5.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle slf4j.api [23]: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))) org.osgi.framework.BundleException: Unresolved constraint in bundle slf4j.api [23]: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002) at org.apache.felix.framework.Felix.startBundle(Felix.java:2045) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304) at java.lang.Thread.run(Thread.java:745) ERROR: Bundle com.datastax.driver.mapping [24] Error starting file:bundles/com.datastax.driver.mapping_2.1.7.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle com.datastax.driver.mapping [24]: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (&(osgi.wiring.package=com.datastax.driver.core)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 15.0: missing requirement [15.0] osgi.wiring.package; (&(osgi.wiring.package=com.codahale.metrics)(version>=3.0.0)(!(version>=4.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.6.0)(!(version>=2.0.0))) [caused by: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle com.datastax.driver.mapping [24]: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (&(osgi.wiring.package=com.datastax.driver.core)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 15.0: missing requirement [15.0] osgi.wiring.package; (&(osgi.wiring.package=com.codahale.metrics)(version>=3.0.0)(!(version>=4.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.6.0)(!(version>=2.0.0))) [caused by: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))]]] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002) at org.apache.felix.framework.Felix.startBundle(Felix.java:2045) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304) at java.lang.Thread.run(Thread.java:745) ____________________________ Welcome to Apache Felix Gogo g! lb START LEVEL 6 ID|State |Level|Name 0|Active | 0|System Bundle (4.4.1) 1|Active | 1|Apache Felix Gogo Command (0.12.0) 2|Active | 1|Apache Felix Gogo Runtime (0.10.0) 3|Active | 1|Apache Felix Gogo Shell (0.10.0) 4|Installed | 5|CAAO-bundle (1.0.0.SNAPSHOT) 5|Active | 5|wrap_mvn_org.apache.xmlrpc_xmlrpc-server_3.1.3 (0.0.0) 6|Active | 5|wrap_mvn_org.apache.xmlrpc_xmlrpc-common_3.1.3 (0.0.0) 7|Active | 5|wrap_mvn_org.apache.httpcomponents_httpcore_4.4.1 (0.0.0) 8|Active | 5|wrap_mvn_org.apache.ws.commons.util_ws-commons-util_1.0.2 (0.0.0) 9|Active | 5|wrap_mvn_xml-apis_xml-apis_1.0.b2 (0.0.0) 10|Installed | 5|slf4j-api (1.6.0) 11|Active | 5|Apache Commons Logging (1.2.0) 12|Active | 5|osgi.cmpn (4.2.0.200908310645) 13|Active | 5|Oracle Corporation's JDBC Driver for MySQL (5.1.36) 14|Active | 5|OSGi R4 Core Bundle (4.1.0) 15|Installed | 5|DataStax Java Driver for Apache Cassandra - Core (2.2.0.rc2) 16|Active | 5|Netty/Handler (4.0.27.Final) 17|Active | 5|Netty/Buffer (4.0.27.Final) 18|Active | 5|Netty/Common (4.0.27.Final) 19|Active | 5|Netty/Transport (4.0.27.Final) 20|Active | 5|Netty/Codec (4.0.27.Final) 21|Active | 5|Guava: Google Core Libraries for Java (16.0.1) 22|Installed | 5|Metrics Core (3.0.2) 23|Installed | 5|slf4j-api (1.7.5) 24|Installed | 5|DataStax Java Driver for Apache Cassandra - Object Mapping (2.1.7) {code} pom of the project can be found at https://github.com/zafarella/caao/blob/add-cassandra-client-and-server/osgi/CAAOOSGiBundle/pom.xml using following command to start it {code:java} mvn clean install -T4C pax:run {code} Is it my config error or the driver is missing something? I am also using enforcer in parent pom as follows: https://github.com/zafarella/caao/blob/add-cassandra-client-and-server/pom.xml#L54 Not getting, what could be wrong. When I don't have driver dependency, bundle works fine. Thanks
    via by Zafar Khaydarov,
  • When launch ReportDesigner we see several errors loading bundles. The plugins listed on logs with errors are: - pentaho-marketplace-di - pentaho-metaverse-core - pdi-dataservice-server-plugin - pentaho-yarn-kettle-plugin +It seems, Report Designer is sharing bundle of plugins that come with BA and DI but are not use or require in design tool.+ The error log: {code} INFO: Setting the server's publish address to be /marketplace 2015-09-18 11:27:12,886 [ 1] ERROR - org.apache.aries.blueprint.container.BlueprintContainerImpl - Unable to start blueprint container for bundle pentaho-marketplace-di org.osgi.service.blueprint.container.ComponentDefinitionException: Unable to instantiate components at org.apache.aries.blueprint.container.BlueprintContainerImpl.instantiateEagerComponents(BlueprintContainerImpl.java:686) at org.apache.aries.blueprint.container.BlueprintContainerImpl.doRun(BlueprintContainerImpl.java:377) at org.apache.aries.blueprint.container.BlueprintContainerImpl.run(BlueprintContainerImpl.java:269) at org.apache.aries.blueprint.container.BlueprintExtender.createContainer(BlueprintExtender.java:294) at org.apache.aries.blueprint.container.BlueprintExtender.createContainer(BlueprintExtender.java:263) at org.apache.aries.blueprint.container.BlueprintExtender.modifiedBundle(BlueprintExtender.java:253) at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$Tracked.customizerModified(BundleHookBundleTracker.java:500) at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$Tracked.customizerModified(BundleHookBundleTracker.java:433) at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$AbstractTracked.track(BundleHookBundleTracker.java:725) at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$Tracked.bundleChanged(BundleHookBundleTracker.java:463) at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$BundleEventHook.event(BundleHookBundleTracker.java:422) at org.apache.felix.framework.util.SecureAction.invokeBundleEventHook(SecureAction.java:1127) at org.apache.felix.framework.util.EventDispatcher.createWhitelistFromHooks(EventDispatcher.java:696) at org.apache.felix.framework.util.EventDispatcher.fireBundleEvent(EventDispatcher.java:484) at org.apache.felix.framework.Felix.fireBundleEvent(Felix.java:4429) at org.apache.felix.framework.Felix.startBundle(Felix.java:2100) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304) at java.lang.Thread.run(Thread.java:745) Caused by: java.lang.NoClassDefFoundError: org/eclipse/jface/window/ApplicationWindow at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:760) at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) at java.net.URLClassLoader.defineClass(URLClassLoader.java:467) at java.net.URLClassLoader.access$100(URLClassLoader.java:73) at java.net.URLClassLoader$1.run(URLClassLoader.java:368) at java.net.URLClassLoader$1.run(URLClassLoader.java:362) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:361) at java.lang.ClassLoader.loadClass(ClassLoader.java:424) at java.lang.ClassLoader.loadClass(ClassLoader.java:357) at org.apache.felix.framework.ExtensionManager$ExtensionManagerWiring.getClassByDelegation(ExtensionManager.java:881) at org.apache.felix.framework.BundleWiringImpl.searchImports(BundleWiringImpl.java:1577) at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1507) at org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:77) at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1993) at java.lang.ClassLoader.loadClass(ClassLoader.java:357) at java.lang.Class.getDeclaredMethods0(Native Method) at java.lang.Class.privateGetDeclaredMethods(Class.java:2701) at java.lang.Class.privateGetPublicMethods(Class.java:2902) at java.lang.Class.getMethods(Class.java:1615) at org.apache.aries.blueprint.utils.ReflectionUtils.doGetPublicMethods(ReflectionUtils.java:146) at org.apache.aries.blueprint.utils.ReflectionUtils.getPublicMethods(ReflectionUtils.java:130) at org.apache.aries.blueprint.utils.ReflectionUtils.getLifecycleMethod(ReflectionUtils.java:114) at org.apache.aries.blueprint.container.BeanRecipe.getDestroyMethod(BeanRecipe.java:634) at org.apache.aries.blueprint.container.BeanRecipe.internalCreate2(BeanRecipe.java:812) at org.apache.aries.blueprint.container.BeanRecipe.internalCreate(BeanRecipe.java:787) at org.apache.aries.blueprint.di.AbstractRecipe$1.call(AbstractRecipe.java:79) at java.util.concurrent.FutureTask.run(FutureTask.java:266) at org.apache.aries.blueprint.di.AbstractRecipe.create(AbstractRecipe.java:88) at org.apache.aries.blueprint.container.BlueprintRepository.createInstances(BlueprintRepository.java:245) at org.apache.aries.blueprint.container.BlueprintRepository.createAll(BlueprintRepository.java:183) at org.apache.aries.blueprint.container.BlueprintContainerImpl.instantiateEagerComponents(BlueprintContainerImpl.java:682) ... 18 more Caused by: java.lang.ClassNotFoundException: org.eclipse.jface.window.ApplicationWindow at java.net.URLClassLoader.findClass(URLClassLoader.java:381) at java.lang.ClassLoader.loadClass(ClassLoader.java:424) at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ... 51 more ERROR: Bundle pentaho-metaverse-core [215] Error starting mvn:pentaho/pentaho-metaverse-core/6.0.0.0-321 (org.osgi.framework.BundleException: Unresolved constraint in bundle pentaho-metaverse-core [215]: Unable to resolve 215.0: missing requirement [215.0] osgi.wiring.package; (osgi.wiring.package=com.tinkerpop.blueprints.impls.tg)) org.osgi.framework.BundleException: Unresolved constraint in bundle pentaho-metaverse-core [215]: Unable to resolve 215.0: missing requirement [215.0] osgi.wiring.package; (osgi.wiring.package=com.tinkerpop.blueprints.impls.tg) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002) at org.apache.felix.framework.Felix.startBundle(Felix.java:2045) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304) at java.lang.Thread.run(Thread.java:745) ERROR: Bundle pdi-dataservice-server-plugin [222] Error starting mvn:pentaho/pdi-dataservice-server-plugin/6.0.0.0-321 (org.osgi.framework.BundleException: Unresolved constraint in bundle pdi-dataservice-server-plugin [222]: Unable to resolve 222.0: missing requirement [222.0] osgi.wiring.package; (osgi.wiring.package=org.pentaho.metaverse.api.model)) org.osgi.framework.BundleException: Unresolved constraint in bundle pdi-dataservice-server-plugin [222]: Unable to resolve 222.0: missing requirement [222.0] osgi.wiring.package; (osgi.wiring.package=org.pentaho.metaverse.api.model) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002) at org.apache.felix.framework.Felix.startBundle(Felix.java:2045) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304) at java.lang.Thread.run(Thread.java:745) 2015-09-18 11:27:13,010 [ 125] ERROR - org.apache.aries.blueprint.container.BlueprintContainerImpl - Unable to start blueprint container for bundle pentaho-yarn-kettle-plugin org.osgi.service.blueprint.container.ComponentDefinitionException: Unable to instantiate components at org.apache.aries.blueprint.container.BlueprintContainerImpl.instantiateEagerComponents(BlueprintContainerImpl.java:686) at org.apache.aries.blueprint.container.BlueprintContainerImpl.doRun(BlueprintContainerImpl.java:377) at org.apache.aries.blueprint.container.BlueprintContainerImpl.run(BlueprintContainerImpl.java:269) at org.apache.aries.blueprint.container.BlueprintExtender.createContainer(BlueprintExtender.java:294) at org.apache.aries.blueprint.container.BlueprintExtender.createContainer(BlueprintExtender.java:263) at org.apache.aries.blueprint.container.BlueprintExtender.modifiedBundle(BlueprintExtender.java:253) at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$Tracked.customizerModified(BundleHookBundleTracker.java:500) at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$Tracked.customizerModified(BundleHookBundleTracker.java:433) at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$AbstractTracked.track(BundleHookBundleTracker.java:725) at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$Tracked.bundleChanged(BundleHookBundleTracker.java:463) at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$BundleEventHook.event(BundleHookBundleTracker.java:422) at org.apache.felix.framework.util.SecureAction.invokeBundleEventHook(SecureAction.java:1127) at org.apache.felix.framework.util.EventDispatcher.createWhitelistFromHooks(EventDispatcher.java:696) at org.apache.felix.framework.util.EventDispatcher.fireBundleEvent(EventDispatcher.java:484) at org.apache.felix.framework.Felix.fireBundleEvent(Felix.java:4429) at org.apache.felix.framework.Felix.startBundle(Felix.java:2100) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304) at java.lang.Thread.run(Thread.java:745) Caused by: java.lang.NoClassDefFoundError: com/pentaho/commons/dsc/IPentahoDscParam at java.lang.Class.getDeclaredConstructors0(Native Method) at java.lang.Class.privateGetDeclaredConstructors(Class.java:2671) at java.lang.Class.getConstructors(Class.java:1651) at org.apache.aries.blueprint.container.BeanRecipe.findMatchingConstructors(BeanRecipe.java:509) at org.apache.aries.blueprint.container.BeanRecipe.getInstance(BeanRecipe.java:327) at org.apache.aries.blueprint.container.BeanRecipe.internalCreate2(BeanRecipe.java:806) at org.apache.aries.blueprint.container.BeanRecipe.internalCreate(BeanRecipe.java:787) at org.apache.aries.blueprint.di.AbstractRecipe.create(AbstractRecipe.java:106) at org.apache.aries.blueprint.di.RefRecipe.internalCreate(RefRecipe.java:62) at org.apache.aries.blueprint.di.AbstractRecipe.create(AbstractRecipe.java:106) at org.apache.aries.blueprint.container.BeanRecipe.getInstance(BeanRecipe.java:268) at org.apache.aries.blueprint.container.BeanRecipe.internalCreate2(BeanRecipe.java:806) at org.apache.aries.blueprint.container.BeanRecipe.internalCreate(BeanRecipe.java:787) at org.apache.aries.blueprint.di.AbstractRecipe$1.call(AbstractRecipe.java:79) at java.util.concurrent.FutureTask.run(FutureTask.java:266) at org.apache.aries.blueprint.di.AbstractRecipe.create(AbstractRecipe.java:88) at org.apache.aries.blueprint.di.RefRecipe.internalCreate(RefRecipe.java:62) at org.apache.aries.blueprint.di.AbstractRecipe.create(AbstractRecipe.java:106) at org.apache.aries.blueprint.container.ServiceRecipe.createService(ServiceRecipe.java:284) at org.apache.aries.blueprint.container.ServiceRecipe.internalGetService(ServiceRecipe.java:251) at org.apache.aries.blueprint.container.ServiceRecipe.internalCreate(ServiceRecipe.java:148) at org.apache.aries.blueprint.di.AbstractRecipe$1.call(AbstractRecipe.java:79) at java.util.concurrent.FutureTask.run(FutureTask.java:266) at org.apache.aries.blueprint.di.AbstractRecipe.create(AbstractRecipe.java:88) at org.apache.aries.blueprint.container.BlueprintRepository.createInstances(BlueprintRepository.java:245) at org.apache.aries.blueprint.container.BlueprintRepository.createAll(BlueprintRepository.java:183) at org.apache.aries.blueprint.container.BlueprintContainerImpl.instantiateEagerComponents(BlueprintContainerImpl.java:682) ... 18 more Caused by: java.lang.ClassNotFoundException: com.pentaho.commons.dsc.IPentahoDscParam at java.net.URLClassLoader.findClass(URLClassLoader.java:381) at java.lang.ClassLoader.loadClass(ClassLoader.java:424) at java.lang.ClassLoader.loadClass(ClassLoader.java:357) at org.apache.felix.framework.ExtensionManager$ExtensionManagerWiring.getClassByDelegation(ExtensionManager.java:881) at org.apache.felix.framework.BundleWiringImpl.searchImports(BundleWiringImpl.java:1577) at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1507) at org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:77) at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1993) at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ... 45 more 2015-09-18 11:28:11,353 [ 58468] ERROR - org.pentaho.di.osgi.KarafLifecycleListener - Error in Blueprint Watcher org.pentaho.osgi.api.IKarafBlueprintWatcher$BlueprintWatcherException: Unknown error in KarafBlueprintWatcher at org.pentaho.osgi.impl.KarafBlueprintWatcherImpl.waitForBlueprint(KarafBlueprintWatcherImpl.java:89) at org.pentaho.di.osgi.KarafLifecycleListener$1.run(KarafLifecycleListener.java:75) at java.lang.Thread.run(Thread.java:745) Caused by: org.pentaho.osgi.api.IKarafBlueprintWatcher$BlueprintWatcherException: Timed out waiting for blueprints to load: pentaho-metaverse-core,pdi-dataservice-server-plugin at org.pentaho.osgi.impl.KarafBlueprintWatcherImpl.waitForBlueprint(KarafBlueprintWatcherImpl.java:77) ... 2 more {code}
    via by Emanuel Teixeira,
  • GitHub comment 473#208308590
    via GitHub by bertfrees
    ,
  • Was trying to follow the example osgi in the repo, but my bundle fails with following message: {code:java} .................. .................. .................. -> Runner has successfully finished his job! -> Waiting for framework exit. ERROR: Bundle caao-osgi-bundle [4] Error starting file:bundles/caao-osgi-bundle_1.0.0.SNAPSHOT.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle caao-osgi-bundle [4]: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=com.codahale.metrics)(version>=3.0.0)(!(version>=4.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.6.0)(!(version>=2.0.0))) [caused by: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))]]) org.osgi.framework.BundleException: Unresolved constraint in bundle caao-osgi-bundle [4]: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=com.codahale.metrics)(version>=3.0.0)(!(version>=4.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.6.0)(!(version>=2.0.0))) [caused by: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))]] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002) at org.apache.felix.framework.Felix.startBundle(Felix.java:2045) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304) at java.lang.Thread.run(Thread.java:745) ERROR: Bundle slf4j.api [10] Error starting file:bundles/slf4j.api_1.6.0.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle slf4j.api [10]: Unable to resolve 10.0: missing requirement [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.5.5))) org.osgi.framework.BundleException: Unresolved constraint in bundle slf4j.api [10]: Unable to resolve 10.0: missing requirement [10.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.5.5)) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002) at org.apache.felix.framework.Felix.startBundle(Felix.java:2045) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304) at java.lang.Thread.run(Thread.java:745) ERROR: Bundle com.datastax.driver.core [15] Error starting file:bundles/com.datastax.driver.core_2.2.0.rc2.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle com.datastax.driver.core [15]: Unable to resolve 15.0: missing requirement [15.0] osgi.wiring.package; (&(osgi.wiring.package=com.codahale.metrics)(version>=3.0.0)(!(version>=4.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.6.0)(!(version>=2.0.0))) [caused by: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))]]) org.osgi.framework.BundleException: Unresolved constraint in bundle com.datastax.driver.core [15]: Unable to resolve 15.0: missing requirement [15.0] osgi.wiring.package; (&(osgi.wiring.package=com.codahale.metrics)(version>=3.0.0)(!(version>=4.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.6.0)(!(version>=2.0.0))) [caused by: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))]] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002) at org.apache.felix.framework.Felix.startBundle(Felix.java:2045) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304) at java.lang.Thread.run(Thread.java:745) ERROR: Bundle com.codahale.metrics.core [22] Error starting file:bundles/com.codahale.metrics.core_3.0.2.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle com.codahale.metrics.core [22]: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.6.0)(!(version>=2.0.0))) [caused by: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))]) org.osgi.framework.BundleException: Unresolved constraint in bundle com.codahale.metrics.core [22]: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.6.0)(!(version>=2.0.0))) [caused by: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002) at org.apache.felix.framework.Felix.startBundle(Felix.java:2045) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304) at java.lang.Thread.run(Thread.java:745) ERROR: Bundle slf4j.api [23] Error starting file:bundles/slf4j.api_1.7.5.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle slf4j.api [23]: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))) org.osgi.framework.BundleException: Unresolved constraint in bundle slf4j.api [23]: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0)) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002) at org.apache.felix.framework.Felix.startBundle(Felix.java:2045) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304) at java.lang.Thread.run(Thread.java:745) ERROR: Bundle com.datastax.driver.mapping [24] Error starting file:bundles/com.datastax.driver.mapping_2.1.7.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle com.datastax.driver.mapping [24]: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (&(osgi.wiring.package=com.datastax.driver.core)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 15.0: missing requirement [15.0] osgi.wiring.package; (&(osgi.wiring.package=com.codahale.metrics)(version>=3.0.0)(!(version>=4.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.6.0)(!(version>=2.0.0))) [caused by: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle com.datastax.driver.mapping [24]: Unable to resolve 24.0: missing requirement [24.0] osgi.wiring.package; (&(osgi.wiring.package=com.datastax.driver.core)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 15.0: missing requirement [15.0] osgi.wiring.package; (&(osgi.wiring.package=com.codahale.metrics)(version>=3.0.0)(!(version>=4.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j)(version>=1.6.0)(!(version>=2.0.0))) [caused by: Unable to resolve 23.0: missing requirement [23.0] osgi.wiring.package; (&(osgi.wiring.package=org.slf4j.impl)(version>=1.6.0))]]] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002) at org.apache.felix.framework.Felix.startBundle(Felix.java:2045) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304) at java.lang.Thread.run(Thread.java:745) ____________________________ Welcome to Apache Felix Gogo g! lb START LEVEL 6 ID|State |Level|Name 0|Active | 0|System Bundle (4.4.1) 1|Active | 1|Apache Felix Gogo Command (0.12.0) 2|Active | 1|Apache Felix Gogo Runtime (0.10.0) 3|Active | 1|Apache Felix Gogo Shell (0.10.0) 4|Installed | 5|CAAO-bundle (1.0.0.SNAPSHOT) 5|Active | 5|wrap_mvn_org.apache.xmlrpc_xmlrpc-server_3.1.3 (0.0.0) 6|Active | 5|wrap_mvn_org.apache.xmlrpc_xmlrpc-common_3.1.3 (0.0.0) 7|Active | 5|wrap_mvn_org.apache.httpcomponents_httpcore_4.4.1 (0.0.0) 8|Active | 5|wrap_mvn_org.apache.ws.commons.util_ws-commons-util_1.0.2 (0.0.0) 9|Active | 5|wrap_mvn_xml-apis_xml-apis_1.0.b2 (0.0.0) 10|Installed | 5|slf4j-api (1.6.0) 11|Active | 5|Apache Commons Logging (1.2.0) 12|Active | 5|osgi.cmpn (4.2.0.200908310645) 13|Active | 5|Oracle Corporation's JDBC Driver for MySQL (5.1.36) 14|Active | 5|OSGi R4 Core Bundle (4.1.0) 15|Installed | 5|DataStax Java Driver for Apache Cassandra - Core (2.2.0.rc2) 16|Active | 5|Netty/Handler (4.0.27.Final) 17|Active | 5|Netty/Buffer (4.0.27.Final) 18|Active | 5|Netty/Common (4.0.27.Final) 19|Active | 5|Netty/Transport (4.0.27.Final) 20|Active | 5|Netty/Codec (4.0.27.Final) 21|Active | 5|Guava: Google Core Libraries for Java (16.0.1) 22|Installed | 5|Metrics Core (3.0.2) 23|Installed | 5|slf4j-api (1.7.5) 24|Installed | 5|DataStax Java Driver for Apache Cassandra - Object Mapping (2.1.7) {code} pom of the project can be found at https://github.com/zafarella/caao/blob/add-cassandra-client-and-server/osgi/CAAOOSGiBundle/pom.xml using following command to start it {code:java} mvn clean install -T4C pax:run {code} Is it my config error or the driver is missing something? I am also using enforcer in parent pom as follows: https://github.com/zafarella/caao/blob/add-cassandra-client-and-server/pom.xml#L54 Not getting, what could be wrong. When I don't have driver dependency, bundle works fine. Thanks
    via by Zafar Khaydarov,
  • The camel-cxf feature doesn't install the camel-spring feature, which is a required dependency. This leads to errors like this one: {noformat} ERROR: Bundle org.apache.camel.camel-cxf [105] Error starting mvn:org.apache.camel/camel-cxf/2.15.1 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.camel.camel-cxf [105]: Unable to resolve 105.0: missing requirement [105.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.camel.spring)(version>=2.15.0)(!(version>=2.16.0)))) org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.camel.camel-cxf [105]: Unable to resolve 105.0: missing requirement [105.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.camel.spring)(version>=2.15.0)(!(version>=2.16.0))) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002) at org.apache.felix.framework.Felix.startBundle(Felix.java:2045) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304) at java.lang.Thread.run(Thread.java:745) ERROR: Bundle org.apache.camel.camel-cxf [105] Error starting/stopping bundle. (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.camel.camel-cxf [105]: Unable to resolve 105.0: missing requirement [105.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.camel.spring)(version>=2.15.0)(!(version>=2.16.0)))) org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.camel.camel-cxf [105]: Unable to resolve 105.0: missing requirement [105.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.camel.spring)(version>=2.15.0)(!(version>=2.16.0))) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002) at org.apache.felix.framework.Felix.startBundle(Felix.java:2045) at org.apache.felix.framework.Felix.setBundleStartLevel(Felix.java:1491) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:334) at java.lang.Thread.run(Thread.java:745) {noformat}
    via by Christian Müller,
    • org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fab.fab-osgi [158]: Unable to resolve 158.0: missing requirement [158.0] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.pax.swissbox.property)(version>=1.7.0)(!(version>=2.0.0))) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002) at org.apache.felix.framework.Felix.startBundle(Felix.java:2045) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304) at java.lang.Thread.run(Thread.java:745)

    Users with the same issue

    davidvanlaatum
    2631 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    13 more bugmates