org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fab.fab-osgi [158]: Unable to resolve 158.0: missing requirement [158.0] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.pax.swissbox.property)(version>=1.7.0)(!(version>=2.0.0)))

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

Do you know how to solve this issue? Write a tip to help other users and build your expert profile.

Solutions on the web

via JBoss Issue Tracker by Paolo Antinori, 1 year ago
Unresolved constraint in bundle io.fabric8.fab.fab-osgi [158]: Unable to resolve 158.0: missing requirement [158.0] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.pax.swissbox.property)(version>=1.7.0)(!(version>=2.0.0)))
via aries-dev by Jean-Baptiste Onofré (JIRA), 1 year ago
Unresolved constraint in bundle org.apache.aries.jmx.core [65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.7.0)(!(version>=2.0.0)))
via GitHub by pires
, 2 years ago
Unresolved constraint in bundle io.fabric8.fabric-agent [65]: Unable to resolve 65.0: missing requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=io.fabric8.api)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)]
via hivmr.com by Unknown author, 1 year ago
Unresolved constraint in bundle io.fabric8.fabric-agent [60]: Unable to resolve 60.0: missing requirement [60.0] osgi.wiring.package; ((osgi.wiring.package=io.fabric8.api)(version=1.0.0)(!(version=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)]
via GitHub by deklanowski
, 2 years ago
Unresolved constraint in bundle org.ops4j.pax.exam.inject [2]: Unable to resolve 2.0: missing requirement [2.0] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.pax.swissbox.tracker)(version>=1.7.0)(!(version>=2.0.0))) [caused by: Unable to
via felix-users by Stijn de Witt, 1 year ago
Unresolved constraint in bundle org.apache.felix.webconsole [1]: Unable to resolve 1.0: missing requirement [1.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.service.http)(version>=1.2.0)(!(version>=2.0.0)))
org.osgi.framework.BundleException: Unresolved constraint in bundle io.fabric8.fab.fab-osgi [158]: Unable to resolve 158.0: missing requirement [158.0] osgi.wiring.package; (&(osgi.wiring.package=org.ops4j.pax.swissbox.property)(version>=1.7.0)(!(version>=2.0.0)))
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002)
at org.apache.felix.framework.Felix.startBundle(Felix.java:2045)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)
at java.lang.Thread.run(Thread.java:745)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.