Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via JBoss Issue Tracker by Paolo Antinori, 1 year ago
io.fabric8.common.util.MultiException: Error updating agent at io.fabric8.agent.DeploymentAgent.install(DeploymentAgent.java:988)[81:io.fabric8.fabric-agent:1.2.0.SNAPSHOT] at io.fabric8.agent.DeploymentAgent.doUpdate(DeploymentAgent.java:593)[81:io.fabric8.fabric-agent:1.2.0.SNAPSHOT] at io.fabric8.agent.DeploymentAgent$2.run(DeploymentAgent.java:313)[81:io.fabric8.fabric-agent:1.2.0.SNAPSHOT] at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)[:1.7.0_65] at java.util.concurrent.FutureTask.run(FutureTask.java:262)[:1.7.0_65] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)[:1.7.0_65] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)[:1.7.0_65] at java.lang.Thread.run(Thread.java:745)[:1.7.0_65]Caused by: org.osgi.framework.BundleException: Uses constraint violation. Unable to resolve bundle revision org.apache.servicemix.bundles.spring-context-support [177.0] because it is exposed to package 'org.apache.commons.logging' from bundle revisions org.ops4j.pax.logging.pax-logging-api [4.0] and org.ops4j.pax.swissbox.optional.jcl [162.0] via two dependency chains.Chain 1: org.apache.servicemix.bundles.spring-context-support [177.0] import: (&(osgi.wiring.package=org.apache.commons.logging)(version>=1.1.1)(!(version>=2.0.0))) | export: osgi.wiring.package=org.apache.commons.logging org.ops4j.pax.logging.pax-logging-api [4.0]Chain 2: org.apache.servicemix.bundles.spring-context-support [177.0] import: (&(osgi.wiring.package=org.apache.velocity.context)(version>=1.5.0)(!(version>=2.0.0))) | export: osgi.wiring.package=org.apache.velocity.context; uses:=org.apache.commons.logging org.apache.servicemix.bundles.velocity [188.0] import: (&(osgi.wiring.package=org.apache.commons.logging)(version>=1.1.0)(!(version>=2.0.0))) | export: osgi.wiring.package=org.apache.commons.logging org.ops4j.pax.swissbox.optional.jcl [162.0] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4006)[org.apache.felix.framework-4.4.1.jar:] at org.apache.felix.framework.Felix.startBundle(Felix.java:2045)[org.apache.felix.framework-4.4.1.jar:] at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:976)[org.apache.felix.framework-4.4.1.jar:] at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:963)[org.apache.felix.framework-4.4.1.jar:] at io.fabric8.agent.DeploymentAgent.install(DeploymentAgent.java:981)[81:io.fabric8.fabric-agent:1.2.0.SNAPSHOT] ... 7 more