java.lang.IllegalStateException: Application was not properly initialized at startup, could not find Factory: javax.faces.render.RenderKitFactory

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via Coderanch by Oleg Tretyakov, 11 months ago
Application was not properly initialized at startup, could not find Factory: javax.faces.render.RenderKitFactory
via coderanch.com by Unknown author, 1 year ago
Application was not properly initialized at startup, could not find Factory: javax.faces.render.RenderKitFactory
via Stack Overflow by Stefan
, 1 year ago
Application was not properly initialized at startup, could not find Factory: javax.faces.context.FacesContextFactory
via Oracle Community by 241478, 4 months ago
Application was not properly initialized at startup, could not find Factory: javax.faces.render.RenderKitFactory
via ibm.com by Unknown author, 1 year ago
Application was not properly initialized at startup, could not find Factory: javax.faces.context.FacesContextFactory
via ibm.com by Unknown author, 2 years ago
Application was not properly initialized at startup, could not find Factory: javax.faces.context.FacesContextFactory
java.lang.IllegalStateException: Application was not properly initialized at startup, could not find Factory: javax.faces.render.RenderKitFactory
at javax.faces.FactoryFinder.getFactory(FactoryFinder.java:256)
at com.ibm.ws.jsf.configuration.FacesConfig.initialize(FacesConfig.java:96)
at com.ibm.ws.jsf.extprocessor.JSFExtensionFactory.createExtensionProcessor(JSFExtensionFactory.java:107)
at com.ibm.ws.webcontainer.webapp.WebApp.initializeExtensionProcessors(WebApp.java:1029)
at com.ibm.ws.wswebcontainer.webapp.WebApp.initialize(WebApp.java:271)
at com.ibm.ws.wswebcontainer.webapp.WebGroup.addWebApplication(WebGroup.java:88)
at com.ibm.ws.wswebcontainer.VirtualHost.addWebApplication(VirtualHost.java:157)
at com.ibm.ws.wswebcontainer.WebContainer.addWebApp(WebContainer.java:653)
at com.ibm.ws.wswebcontainer.WebContainer.addWebApplication(WebContainer.java:606)
at com.ibm.ws.webcontainer.component.WebContainerImpl.install(WebContainerImpl.java:333)
at com.ibm.ws.webcontainer.component.WebContainerImpl.start(WebContainerImpl.java:549)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.start(ApplicationMgrImpl.java:1295)
at com.ibm.ws.runtime.component.DeployedApplicationImpl.fireDeployedObjectStart(DeployedApplicationImpl.java:1129)
at com.ibm.ws.runtime.component.DeployedModuleImpl.start(DeployedModuleImpl.java:567)
at com.ibm.ws.runtime.component.DeployedApplicationImpl.start(DeployedApplicationImpl.java:814)
at com.ibm.ws.runtime.component.ApplicationMgrImpl.startApplication(ApplicationMgrImpl.java:948)
at com.ibm.wsspi.runtime.component.WsComponentImpl$_AsynchInitializer.run(WsComponentImpl.java:340)
at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1498)

Users with the same issue

4 times, 3 weeks ago
2 times, 7 months ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
15 more bugmates

Know the solutions? Share your knowledge to help other developers to debug faster.