java.lang.IllegalArgumentException: Bad artifact coordinates postgresql-metadata-storage:0.8.3, expected format is <groupId>:<artifactId>[:<extension>[:<classifier>]]:<version>

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via Google Groups by Luan Cooper, 1 year ago
Bad artifact coordinates postgresql-metadata-storage:0.8.3, expected format is <groupId>:<artifactId>[:<extension>[:<classifier>]]:<version>
via GitHub by pabl0rg
, 6 months ago
Bad artifact coordinates file://./lib/jrobin-1.5.9.jar, expected format is <groupId>:<artifactId>[:<extension>[:<classifier>]]:<version>
java.lang.IllegalArgumentException: Bad artifact coordinates postgresql-metadata-storage:0.8.3, expected format is <groupId>:<artifactId>[:<extension>[:<classifier>]]:<version>
at org.eclipse.aether.artifact.DefaultArtifact.(DefaultArtifact.java:68)
at io.druid.initialization.Initialization.getClassLoaderForCoordinates(Initialization.java:216)
at io.druid.cli.Main.main(Main.java:84)

Users with the same issue

5 times, 3 weeks ago

Know the solutions? Share your knowledge to help other developers to debug faster.