java.lang.NoClassDefFoundError

com/temenos/tocf/framework/inbound/pipeline/PipelineContext

Samebug tips1

Look if your classpath is correct, and check if the versions of your libraries match the version you described in your pom.xml


rafaelrafael

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Stack trace

  • java.lang.NoClassDefFoundError: com/temenos/tocf/framework/inbound/pipeline/PipelineContext at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631) at java.lang.ClassLoader.defineClass(ClassLoader.java:615) at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141) at java.net.URLClassLoader.defineClass(URLClassLoader.java:283) at java.net.URLClassLoader.access$000(URLClassLoader.java:58) at java.net.URLClassLoader$1.run(URLClassLoader.java:197) at java.net.URLClassLoader.findClass(URLClassLoader.java:190) at java.lang.ClassLoader.loadClass(ClassLoader.java:306) at java.lang.ClassLoader.loadClass(ClassLoader.java:247) at com.temenos.tocf.t24ra.T24ResourceAdapter.<init>(T24ResourceAdapter.java:42) at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39) at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27) at java.lang.reflect.Constructor.newInstance(Constructor.java:513) at java.lang.Class.newInstance0(Class.java:357) at java.lang.Class.newInstance(Class.java:310) at weblogic.connector.security.layer.AdapterLayer.newInstance(AdapterLayer.java:1434) at weblogic.connector.common.RAInstanceManager.initialize(RAInstanceManager.java:1099) at weblogic.connector.common.RAInstanceManager.<init>(RAInstanceManager.java:356) at weblogic.connector.deploy.ConnectorModule.prepare(ConnectorModule.java:198) at weblogic.application.internal.flow.ModuleListenerInvoker.prepare(ModuleListenerInvoker.java:199) at weblogic.application.internal.flow.DeploymentCallbackFlow$1.next(DeploymentCallbackFlow.java:517)

Write tip

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

Users with the same issue

mauritiusmauritius
Once,
junior_cEngineerjunior_cEngineer
Once,
Unknown visitor
Unknown visitorOnce,
Unknown visitor
Unknown visitorOnce,
andyglickandyglick
2 times, last one
165 more bugmates