java.lang.NoClassDefFoundError: org/eclipse/aether/spi/connector/Transfer$State

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

,

If JVM throws ClassNotFoundException the class is not found in classpath. Seems you are missing hibernate dependency in your project set up. Try downloading hibernate-core.jar and add to your project classpath.

Solutions on the web

via GitHub by iambmelt
, 2 years ago
org/eclipse/aether/spi/connector/Transfer$State
via cocolog-nifty.com by Unknown author, 1 year ago
via cocolog-nifty.com by Unknown author, 1 year ago
org/eclipse/aether/spi/connector/Transfer$State
via JBoss Issue Tracker by Ondrej Zizka, 1 year ago
org/eclipse/aether/spi/connector/Transfer$State
java.lang.NoClassDefFoundError: org/eclipse/aether/spi/connector/Transfer$State
at org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy.loadClass(SelfFirstStrategy.java:50)
at org.codehaus.plexus.classworlds.realm.ClassRealm.unsynchronizedLoadClass(ClassRealm.java:271)
at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:247)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)

Users with the same issue

Samebug visitor profile picture
Unknown user
2 times, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 2 years ago
Once, 2 weeks ago
4 times, 3 months ago
2 times, 5 months ago
96 more bugmates

Know the solutions? Share your knowledge to help other developers to debug faster.