com.izforge.izpack.api.exception.CompilerException

resources/JBoss4/xml/updateScript.xml:72: <installerrequirement> requires attribute 'severity'

Solutions on the web3

  • via Google Groups by Oliver Kersten, 6 months ago
    resources/JBoss4/xml/updateScript.xml:72: <installerrequirement> requires attribute 'severity'
  • via Google Groups by Thibault Duchateau, 2 weeks ago
    .../instal l.xml:53: <listener> requires attribute 'classname'
  • via izpack.org by Unknown author, 1 year ago
    /home/rkrell/IzPack_Installer/trunk/src/main/izpack/install.xml:6: is not an IzPack XML installation file
  • Stack trace

    • com.izforge.izpack.api.exception.CompilerException: resources/JBoss4/xml/updateScript.xml:72: <installerrequirement> requires attribute 'severity' at com.izforge.izpack.ant.IzpackAntRunnable.run(IzpackAntRunnable.java:83) at java.lang.Thread.run(Thread.java:745) Caused by: com.izforge.izpack.api.exception.CompilerException: resources/JBoss4/xml/updateScript.xml:72: <installerrequirement> requires attribute 'severity' at com.izforge.izpack.compiler.helper.AssertionHelper.parseError(AssertionHelper.java:64) at com.izforge.izpack.compiler.helper.XmlCompilerHelper.requireAttribute(XmlCompilerHelper.java:203) at com.izforge.izpack.compiler.CompilerConfig.addDynamicInstallerRequirement(CompilerConfig.java:2702) at com.izforge.izpack.compiler.CompilerConfig.executeCompiler(CompilerConfig.java:329) at com.izforge.izpack.ant.IzpackAntRunnable.run(IzpackAntRunnable.java:79) ... 1 more

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    You are the first who have seen this exception. Write a tip to help other users and build your expert profile.