java.lang.NoClassDefFoundError: org/apache/commons/lang3/builder/HashCodeBuilder

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

,
Expert tip

A few things cause this exception:
1) Check if you have all jars and if they're in the correct path.
2) Your classpath might be broken, you can define it in the command line with java -cp yourClassPath or at your IDE if you're using one.

,

you can change your scala version to 2.11.11

Solutions on the web

via Google Groups by Ignacio Baca Moreno-Torres, 1 year ago
org/apache/commons/lang3/builder/HashCodeBuilder
via Google Groups by Ignacio Baca Moreno-Torres, 1 year ago
org/apache/commons/lang3/builder/HashCodeBuilder
java.lang.ClassNotFoundException: org.apache.commons.lang3.builder.HashCodeBuilder
at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
at java.util.HashMap.hash(HashMap.java:338)
at java.util.HashMap.put(HashMap.java:611)
at com.google.gwt.junit.RunStyleHtmlUnit.addBrowser(RunStyleHtmlUnit.java:211)
at com.google.gwt.junit.RunStyleHtmlUnit.(RunStyleHtmlUnit.java:202)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:264)
at com.google.gwt.junit.JUnitShell.createRunStyle(JUnitShell.java:1179)
at com.google.gwt.dev.DevModeBase.startUp(DevModeBase.java:913)
at com.google.gwt.junit.JUnitShell.getUnitTestShell(JUnitShell.java:696)
at com.google.gwt.junit.JUnitShell.runTest(JUnitShell.java:670)
at junit.framework.TestCase.runBare(TestCase.java:134)
at junit.framework.TestResult$1.protect(TestResult.java:110)
at junit.framework.TestResult.runProtected(TestResult.java:128)
at junit.framework.TestResult.run(TestResult.java:113)
at junit.framework.TestCase.run(TestCase.java:124)
at junit.framework.TestSuite.runTest(TestSuite.java:232)
at junit.framework.TestSuite.run(TestSuite.java:227)
at junit.framework.TestSuite.runTest(TestSuite.java:232)
at junit.framework.TestSuite.run(TestSuite.java:227)
at junit.framework.TestSuite.runTest(TestSuite.java:232)
at junit.framework.TestSuite.run(TestSuite.java:227)
at org.codehaus.mojo.gwt.test.MavenTestRunner.doRun(MavenTestRunner.java:105)
at junit.textui.TestRunner.start(TestRunner.java:180)
at org.codehaus.mojo.gwt.test.MavenTestRunner.main(MavenTestRunner.java:63)

Users with the same issue

Once, 1 day ago
Once, 2 days ago
2 times, 5 days ago
Once, 5 days ago
Once, 5 days ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.