java.lang.ClassNotFoundException

Didn't find class "de.demo.can2s.MainActivity" on path: DexPathList[[zip file "/data/app/de.demo.can2s-2.apk"],nativeLibraryDirectories=[/data/app-lib/de.demo.can2s-2, /system/lib]]*

Samebug tips1

You need to setup a GlideModule before use Glide.

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web2751

  • via Unknown by markus.wiesenbacher,
  • Stack trace

    • java.lang.ClassNotFoundException: Didn't find class "de.demo.can2s.MainActivity" on path: DexPathList[[zip file "/data/app/de.demo.can2s-2.apk"],nativeLibraryDirectories=[/data/app-lib/de.demo.can2s-2, /system/lib]]* at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2110) at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2233) at android.app.ActivityThread.access$800(ActivityThread.java:135) at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1196) at android.os.Handler.dispatchMessage(Handler.java:102) at android.os.Looper.loop(Looper.java:136) at android.app.ActivityThread.main(ActivityThread.java:5001) at java.lang.reflect.Method.invokeNative(Native Method) at java.lang.reflect.Method.invoke(Method.java:515) at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:785) at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:601) at dalvik.system.NativeStart.main(Native Method) Caused by: java.lang.ClassNotFoundException: Didn't find class "de.demo.can2s.MainActivity" on path: DexPathList[[zip file "/data/app/de.demo.can2s.apk"],nativeLibraryDirectories=[/data/app-lib/de.demo.can2s, /system/lib]]* at dalvik.system.BaseDexClassLoader.findClass(BaseDexClassLoader.java:56) at java.lang.ClassLoader.loadClass(ClassLoader.java:497) at java.lang.ClassLoader.loadClass(ClassLoader.java:457) at android.app.Instrumentation.newActivity(Instrumentation.java:1061) at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2101) ... 11 more

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown visitor
    Unknown visitorOnce,
    filipebatistafilipebatista
    Once,
    Indri YunitaIndri Yunita
    4 times, last one
    Unknown visitor
    Unknown visitorOnce,
    Unknown visitor
    Unknown visitorOnce,
    158 more bugmates