org.jboss.weld.exceptions.DeploymentException: WELD-001410: The injection point has non-proxyable dependencies: [BackedAnnotatedField] @Inject private org.wildfly.swarm.container.runtime.RuntimeDeployer.defaultDeploymentCreator

Google Groups | PCB | 5 months ago
tip
Do you know that we can give you better hits? Get more relevant results from Samebug’s stack trace search.
  1. 0

    Unittest problem

    Google Groups | 5 months ago | PCB
    org.jboss.weld.exceptions.DeploymentException: WELD-001410: The injection point has non-proxyable dependencies: [BackedAnnotatedField] @Inject private org.wildfly.swarm.container.runtime.RuntimeDeployer.defaultDeploymentCreator
  2. 0

    Running Arquillian tests fails due to non proxyable classes in swarm (2017.2.0)

    Google Groups | 2 weeks ago | Rene B.
    org.jboss.weld.exceptions.DeploymentException: WELD-001410: The injection point has non-proxyable dependencies: [BackedAnnotatedField] @Inject private org.wildfly.swarm.container.runtime.RuntimeDeployer.defaultDeploymentCreator

    Root Cause Analysis

    1. org.jboss.weld.exceptions.DeploymentException

      WELD-001410: The injection point has non-proxyable dependencies: [BackedAnnotatedField] @Inject private org.wildfly.swarm.container.runtime.RuntimeDeployer.defaultDeploymentCreator

      at org.wildfly.swarm.container.runtime.RuntimeDeployer.defaultDeploymentCreator()
    2. org.wildfly.swarm
      RuntimeDeployer.defaultDeploymentCreator
      1. org.wildfly.swarm.container.runtime.RuntimeDeployer.defaultDeploymentCreator(RuntimeDeployer.java:0)
      1 frame