java.lang.NoClassDefFoundError

org/apache/http/conn/scheme/SchemeSocketFactory

Samebug tips9

A few things cause this exception: 1) Check if you have all jars and if they're in the correct path when running. 2) Your classpath might be broken, you can define it in the command line with "java -cp yourClassPath" or at your IDE if you're using one.

If you're using Hibernate, this indicates you're missing FasterXML Classmate dependency, which you can add to your dependencies. To add it, the groupId is com.fasterxml and artifactId is Classmate.

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web19475

  • via Google Groups by SrinivasGS, 1 year ago
    org/apache/http/conn/scheme/ SchemeSocketFactory
  • org/apache/http/conn/scheme/SchemeSocketFactory
  • via Google Groups by rakesh, 6 months ago
    org/apache/http/conn/scheme/SchemeSocketFactory
  • Stack trace

    • java.lang.NoClassDefFoundError: org/apache/http/conn/scheme/SchemeSocketFactory at org.openqa.selenium.remote.HttpCommandExecutor.<init>(HttpCommandExecutor.java:117) at com.google.android.testing.nativedriver.client.AndroidNativeDriverBuilder.withServer(Unknown Source) at com.google.android.testing.nativedriver.client.AndroidNativeDriverBuilder.withDefaultServer(Unknown Source) at com.example.android.notepad.SeleniumTest.LaunchTest.getDriver(LaunchTest.java:44) at com.example.android.notepad.SeleniumTest.LaunchTest.setUp(LaunchTest.java:33) at junit.framework.TestCase.runBare(TestCase.java:128) at junit.framework.TestResult$1.protect(TestResult.java:106) at junit.framework.TestResult.runProtected(TestResult.java:124) at junit.framework.TestResult.run(TestResult.java:109) at junit.framework.TestCase.run(TestCase.java:120) at junit.framework.TestSuite.runTest(TestSuite.java:230) at junit.framework.TestSuite.run(TestSuite.java:225) at org.eclipse.jdt.internal.junit.runner.junit3.JUnit3TestReference.run(JUnit3TestReference.java:130) at org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:467) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:683) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:390) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:197) Caused by: java.lang.ClassNotFoundException: org.apache.http.conn.scheme.SchemeSocketFactory at java.net.URLClassLoader$1.run(URLClassLoader.java:202) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:190) at java.lang.ClassLoader.loadClass(ClassLoader.java:306) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301) at java.lang.ClassLoader.loadClass(ClassLoader.java:247) ... 18 more

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 2 years ago
    Unknown user
    Once, 10 months ago
    Unknown user
    Once, 11 months ago
    Unknown user
    Once, 1 year ago
    2363 more bugmates