org.craftercms.engine.exception.ScriptException: provider type 'alfresco' not found. Check server config.]

Google Groups | Deepesh Nandal | 2 years ago
tip
Click on the to mark the solution that helps you, Samebug will learn from it.
As a community member, you’ll be rewarded for you help.
  1. 0

    upgrade to 2.5.0 -- provider type 'alfresco' not found.

    Google Groups | 2 years ago | Deepesh Nandal
    org.craftercms.engine.exception.ScriptException: provider type 'alfresco' not found. Check server config.]

    Root Cause Analysis

    1. java.lang.RuntimeException

      provider type 'alfresco' not found. Check server config.

      at org.craftercms.studio.impl.v1.service.security.MappedSecurityProvider.lookupProvider()
    2. org.craftercms.studio
      SecurityService$authenticate.call
      1. org.craftercms.studio.impl.v1.service.security.MappedSecurityProvider.lookupProvider(MappedSecurityProvider.java:61)
      2. org.craftercms.studio.impl.v1.service.security.MappedSecurityProvider.authenticate(MappedSecurityProvider.java:91)
      3. org.craftercms.studio.impl.v1.service.security.SecurityServiceImpl.authenticate(SecurityServiceImpl.java:53)
      4. org.craftercms.studio.api.v1.service.security.SecurityService$authenticate.call(Unknown Source)
      4 frames
    3. Groovy
      AbstractCallSite.call
      1. org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCall(CallSiteArray.java:45)
      2. org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:110)
      3. org.codehaus.groovy.runtime.callsite.AbstractCallSite.call(AbstractCallSite.java:130)
      3 frames