org.osgi.framework.BundleException: Could not resolve module: org.eclipse.rap.rwt.osgi [26] Unresolved requirement: Import-Package: javax.servlet; version="[2.5.0,3.2.0)"

tip
Click on the to mark the solution that helps you, Samebug will learn from it.
As a community member, you’ll be rewarded for you help.
  1. 0

    RAP War not being deployed correctly

    Stack Overflow | 4 months ago | Marcelo Amoretti
    org.osgi.framework.BundleException: Could not resolve module: org.eclipse.rap.rwt.osgi [26] Unresolved requirement: Import-Package: javax.servlet; version="[2.5.0,3.2.0)"
  2. 0

    [Débutant - RAP] Erreur non maitrisée à l'exécution

    developpez.net | 2 years ago
    org.osgi.framework.BundleException: Could not resolve module: org.eclipse.rap.ui.workbench [21] Unresolved requirement: Import-Package: org.eclipse.rap.rwt.osgi; version="[2.3.0,3.0.0)"
  3. 0

    Error deploying RAP Application to servlet container

    Stack Overflow | 3 weeks ago | Marcelo Amoretti
    org.osgi.framework.BundleException: Could not resolve module: org.eclipse.rap.rwt.testfixture [131] Unresolved requirement: Import-Package: javax.servlet; version="[3.1.0,4.0.0)"
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Eclipse Community Forums: Gyrex » what's the correct eclipse version shall I use for gyrex 1.3.2?

    eclipse.org | 12 months ago
    org.osgi.framework.BundleException: Could not resolve module: org.eclipse.gyrex.http.jersey [159] Unresolved requirement: Import-Package: org.eclipse.persistence.jaxb.rs; version="[2.4.0,3.0.0)"; resolution:="optional" Unresolved requirement: Import-Package: org.objectweb.asm; version="[3.1.0,4.0.0)"

    47 unregistered visitors
    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. org.osgi.framework.BundleException

      Could not resolve module: org.eclipse.rap.rwt.osgi [26] Unresolved requirement: Import-Package: javax.servlet; version="[2.5.0,3.2.0)"

      at org.eclipse.osgi.container.Module.start()
    2. Eclipse OSGi
      EventManager$EventThread.run
      1. org.eclipse.osgi.container.Module.start(Module.java:444)
      2. org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
      3. org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1600)
      4. org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
      5. org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
      6. org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
      7. org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
      8. org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
      8 frames