java.lang.RuntimeException: nope


Samebug tips1

This is a bug in some versions of the Arduino IDE. Try updating to the version 1.6.12 or further.


8 months ago
Expert tip

Solutions on the web9

Solution icon of github
via GitHub by johnynek
, 11 months ago
nope

Solution icon of github
via GitHub by petemounce
, 9 months ago
nope

Solution icon of github
via GitHub by petemounce
, 9 months ago
nope

Solution icon of github
via GitHub by petemounce
, 11 months ago
nope

Solution icon of github
via GitHub by petemounce
, 11 months ago
nope

Solution icon of github
via GitHub by petemounce
, 11 months ago
nope

Solution icon of github
via GitHub by petemounce
, 9 months ago
nope

Solution icon of github
via GitHub by petemounce
, 9 months ago
nope

Solution icon of github
nope

Stack trace

java.lang.RuntimeException: nope
	at io.bazel.rulesscala.scalac.ScalaCInvoker.main(ScalaCInvoker.java:338)
Caused by: java.io.IOException: Cannot run program "external/local_jdk/bin/javac ": error=2, No such file or directory
	at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
	at io.bazel.rulesscala.scalac.ScalaCInvoker.compileJavaSources(ScalaCInvoker.java:293)
	at io.bazel.rulesscala.scalac.ScalaCInvoker.processRequest(ScalaCInvoker.java:237)
	at io.bazel.rulesscala.scalac.ScalaCInvoker.main(ScalaCInvoker.java:334)

Caused by: java.io.IOException: error=2, No such file or directory
	at java.lang.UNIXProcess.forkAndExec(Native Method)
	at java.lang.UNIXProcess.<init>(UNIXProcess.java:247)
	at java.lang.ProcessImpl.start(ProcessImpl.java:134)
	at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
	... 3 more

Write tip

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

Users with the same issue

Once, 2 weeks ago
5 times, 3 months ago
16 times, 5 months ago
Once, 10 months ago
Samebug visitor profile picture
Unknown user
Once, 10 months ago
153 more bugmates