java.lang.UnsatisfiedLinkError

tip

This happens sometimes when Android fails to load the necessary libraries when you install an app. Try reinstalling it or telling your client to reinstall it, as it seems to correctly install the libraries and fixes the problem.


rafaelrafael

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • GitHub comment 413#271182921
    via GitHub by dixonwille
    ,
  • GitHub comment 765#271564666
    via GitHub by kjm16216
    ,
  • Can't build a clean checkout
    via GitHub by nrother
    ,
  • SnappyJava error (Mac OSX )
    via GitHub by remi-parain
    ,
  • UnsatisfiedLinkError with JNI
    via Stack Overflow by Ahmed Ebaid
    ,
    • java.lang.UnsatisfiedLinkError: no wpilibJavaJNI in java.library.path at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1857) at java.lang.Runtime.loadLibrary0(Runtime.java:870) at java.lang.System.loadLibrary(System.java:1119) at edu.wpi.first.wpilibj.hal.JNIWrapper.<clinit>(JNIWrapper.java:22) at edu.wpi.first.wpilibj.RobotBase.initializeHardwareConfiguration(RobotBase.java:171) at edu.wpi.first.wpilibj.RobotBase.main(RobotBase.java:194)

    Users with the same issue

    rprp
    11 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor2 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    276 more bugmates