java.lang.UnsatisfiedLinkError: Cannot load library: find_library[1254]: 138 ''libmozglue.so'' failed to load previously

mozilla.com | 2 months ago
tip
Your exception is missing from the Samebug knowledge base.
Here are the best solutions we found on the Internet.
Click on the to mark the helpful solution and get rewards for you help.
  1. 0

    2015-09-30 FennecAndroid Release 41 Startup Crash Report

    mozilla.com | 2 months ago
    java.lang.UnsatisfiedLinkError: Cannot load library: find_library[1220]: 90 ''libmozglue.so'' failed to load previously
  2. 0

    Impacted Cases ============== I have a ionic project, which include some .so libraries, it runs OK. For better performance, I add the cordova-plugin-crosswalk-webview. After adding the plugin, the App works fine in Android 4.4 and above, but failed in 4.2 and 4.1 ( I did not test 4.3). I tried cordova-plugin-crosswalk-webview 2.0.0, 1,8.0, 1.7.0, all crashed with the java.lang.UnsatisfiedLinkError error. java.lang.UnsatisfiedLinkError: Cannot load library: find_library[1201]: 1502 'libics.so' failed to load previously at java.lang.Runtime.loadLibrary(Runtime.java:370) at java.lang.System.loadLibrary(System.java:535) Please help on this issue. Thanks. Btw, I capture the log on Sony LT22i (Android 4.1.2) and attached it. I also root the mobile and check the app directory, the libraries are in places: root@android:/data/data/com.easyzhuang.app/lib # pwd /data/data/com.easyzhuang.app/lib root@android:/data/data/com.easyzhuang.app/lib # ls libgb.so libics.so libjb.so libjingle_peerconnection_so.so liblp.so libpl_droidsonroids_gif.so libpl_droidsonroids_gif_surface.so libsipsua.so libvtcff.so libxwalkcore.so libxwalkdummy.so root@android:/data/data/com.easyzhuang.app/lib # Reproduce Test Steps ==================== Expected Outcome ================ Actual Outcome ============== Test Case Source Code ===================== Test Builds =========== Issue Analysis ==============

    JIRA | 7 months ago | Huang, Churnrong
    java.lang.UnsatisfiedLinkError: Cannot load library: find_library[1201]: 1502 'libics.so' failed to load previously
  3. 0

    Emgu CV for Android throwing Exception Java.Lang.UnsatisfiedLinkError

    Stack Overflow | 5 years ago | Nitin Agarwal
    java.lang.UnsatisfiedLinkError: Cannot load library: find_library[1199]: 37 'libopencv_highgui.so' failed to load previously</p> <pre><code> at java.lang.Runtime.loadLibrary(Runtime.java:370)
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  1. malhobayyeb 2 times, last 4 months ago
  2. Alexandru Popa 6 times, last 4 months ago
  3. franky li 14 times, last 5 months ago
  4. pranavprakash 4 times, last 4 months ago
  5. ivotje50 36 times, last 6 months ago
14 more registered users
2 unregistered visitors
Not finding the right solution?
Take a tour to get the most out of Samebug.

Tired of useless tips?

Automated exception search integrated into your IDE

Root Cause Analysis

  1. java.lang.UnsatisfiedLinkError

    Cannot load library: find_library[1254]: 138 ''libmozglue.so'' failed to load previously

    at java.lang.Runtime.loadLibrary()
  2. Java RT
    Runtime.loadLibrary
    1. java.lang.Runtime.loadLibrary(Runtime.java)
    1 frame