java.io.IOException

tip

Check if you didn't set RequestProperty Content-Type to the wrong type or if you're trying to send the wrong file to the server.

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    • java.io.IOException: Server returned HTTP response code: 403 for URL: https://kubernetes.default.svc.cluster.local/api/v1
    • amespaces/e2e-tests-examples-xgvfv/endpoints/hazelcast at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1840)[na:1.8.0_92-internal] at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1441)[na:1.8.0_92-internal] at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:254)[na:1.8.0_92-internal] at com.github.pires.hazelcast.HazelcastDiscoveryController.run(HazelcastDiscoveryController.java:118)[classes!/:na] at org.springframework.boot.SpringApplication.callRunner(SpringApplication.java:798)[spring-boot-1.4.0.RELEASE.jar!/:1.4.0.RELEASE] at org.springframework.boot.SpringApplication.callRunners(SpringApplication.java:782)[spring-boot-1.4.0.RELEASE.jar!/:1.4.0.RELEASE] at org.springframework.boot.SpringApplication.afterRefresh(SpringApplication.java:769)[spring-boot-1.4.0.RELEASE.jar!/:1.4.0.RELEASE] at org.springframework.boot.SpringApplication.run(SpringApplication.java:314)[spring-boot-1.4.0.RELEASE.jar!/:1.4.0.RELEASE] at org.springframework.boot.builder.SpringApplicationBuilder.run(SpringApplicationBuilder.java:134)[spring-boot-1.4.0.RELEASE.jar!/:1.4.0.RELEASE] at com.github.pires.hazelcast.Application.main(Application.java:28)[classes!/:na] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)[na:1.8.0_92-internal] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)[na:1.8.0_92-internal] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)[na:1.8.0_92-internal] at java.lang.reflect.Method.invoke(Method.java:498)[na:1.8.0_92-internal] at org.springframework.boot.loader.MainMethodRunner.run(MainMethodRunner.java:48)[bootstrapper.jar:na] at org.springframework.boot.loader.Launcher.launch(Launcher.java:87)[bootstrapper.jar:na] at org.springframework.boot.loader.Launcher.launch(Launcher.java:50)[bootstrapper.jar:na] at org.springframework.boot.loader.JarLauncher.main(JarLauncher.java:58)[bootstrapper.jar:na]

    Users with the same issue

    Unknown visitor
    Unknown visitor1 times, last one,
    tfrtfr
    35 times, last one,
    davidvanlaatumdavidvanlaatum
    1 times, last one,
    pnaranjapnaranja
    3 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    90 more bugmates