java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • iREPORT 5.6 Error at start
    via Stack Overflow by Omar Noboa Morante
    ,
  • JavaFX, JasperReports and JRDataSource
    via Stack Overflow by Lal
    ,
    • java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory at net.sf.jasperreports.engine.util.JRLoader.<clinit>(JRLoader.java:81) at net.sf.jasperreports.engine.JRPropertiesUtil.loadProperties(JRPropertiesUtil.java:99) at net.sf.jasperreports.engine.DefaultJasperReportsContext.initProperties(DefaultJasperReportsContext.java:94) at net.sf.jasperreports.engine.DefaultJasperReportsContext.<init>(DefaultJasperReportsContext.java:71) at net.sf.jasperreports.engine.DefaultJasperReportsContext.<clinit>(DefaultJasperReportsContext.java:59) at com.jaspersoft.ireport.designer.IRLocalJasperReportsContext.getInstance(IRLocalJasperReportsContext.java:54) at com.jaspersoft.ireport.designer.IRLocalJasperReportsContext.getUtilities(IRLocalJasperReportsContext.java:103) at com.jaspersoft.ireport.designer.IReportManager.reloadQueryExecuters(IReportManager.java:421) at com.jaspersoft.ireport.designer.IReportManager.getQueryExecuters(IReportManager.java:1345) at com.jaspersoft.ireport.designer.IReportManager.initialize(IReportManager.java:560) at com.jaspersoft.ireport.designer.IReportManager.getInstance(IReportManager.java:653) at com.jaspersoft.ireport.jasperserver.Installer.restored(Installer.java:23) at org.netbeans.core.startup.NbInstaller.loadCode(NbInstaller.java:419) at org.netbeans.core.startup.NbInstaller.load(NbInstaller.java:340) at org.netbeans.ModuleManager.enable(ModuleManager.java:906) at org.netbeans.core.startup.ModuleList.installNew(ModuleList.java:428) at org.netbeans.core.startup.ModuleList.trigger(ModuleList.java:364) at org.netbeans.core.startup.ModuleSystem.restore(ModuleSystem.java:276) at org.netbeans.core.startup.Main.getModuleSystem(Main.java:165) at org.netbeans.core.startup.Main.start(Main.java:312) at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:110)[catch] at java.lang.Thread.run(Thread.java:745)
    No Bugmate found.