java.lang.UnsatisfiedLinkError

no icedtea-sound in java.library.path


Samebug tips1

This happens sometimes when Android fails to load the necessary libraries when you install an app. Try reinstalling it or telling your client to reinstall it, as it seems to correctly install the libraries and fixes the problem.

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.


Solutions on the web4568

Solution icon of github
no icedtea-sound in java.library.path

Solution icon of github
via GitHub by 190n
, 1 year ago
no icedtea-sound in java.library.path

Solution icon of github
via GitHub by DaAwesomeP
, 7 months ago
no icedtea-sound in java.library.path

Solution icon of coderanch
via Coderanch by Venkatesh Ram, 8 months ago
no JMagick in java.library.path

Solution icon of coderanch
via Coderanch by Sree Nivas, 1 year ago
no Jawin in java.library.path

Solution icon of coderanch
via Coderanch by Murali Rajamanickam, 1 year ago
no jdic in java.library.path

Solution icon of coderanch
via Coderanch by js sj, 1 year ago
no jRegistryKey in java.library.path

Solution icon of coderanch
no jdic in java.library.path

Solution icon of coderanch
via Coderanch by Kaustubh G Sharma, 8 months ago
no ocijdbc10 in java.library.path

Solution icon of coderanch
via Coderanch by Smita Jain, 9 months ago
no muxer in java.library.path

Stack trace

  • java.lang.UnsatisfiedLinkError: no icedtea-sound in java.library.path at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1867) at java.lang.Runtime.loadLibrary0(Runtime.java:870) at java.lang.System.loadLibrary(System.java:1122) at org.classpath.icedtea.pulseaudio.SecurityWrapper.loadNativeLibrary(SecurityWrapper.java:66) at org.classpath.icedtea.pulseaudio.EventLoop.<clinit>(EventLoop.java:97) at org.classpath.icedtea.pulseaudio.PulseAudioMixer.openImpl(PulseAudioMixer.java:654) at org.classpath.icedtea.pulseaudio.PulseAudioMixer.openLocal(PulseAudioMixer.java:588) at org.classpath.icedtea.pulseaudio.PulseAudioMixer.openLocal(PulseAudioMixer.java:584) at org.classpath.icedtea.pulseaudio.PulseAudioMixer.open(PulseAudioMixer.java:579) at org.classpath.icedtea.pulseaudio.PulseAudioDataLine.open(PulseAudioDataLine.java:94) at org.classpath.icedtea.pulseaudio.PulseAudioSourceDataLine.open(PulseAudioSourceDataLine.java:75) at org.classpath.icedtea.pulseaudio.PulseAudioSourceDataLine.open(PulseAudioSourceDataLine.java:90) at org.eclipse.smarthome.io.javasound.internal.AudioPlayer.run(AudioPlayer.java:63)

Write tip

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 2 months ago
Samebug visitor profile picture
Unknown user
Once, 5 months ago
15 times, 5 months ago
Samebug visitor profile picture
Unknown user
Once, 6 months ago
9 times, 6 months ago
277 more bugmates