java.net.BindException

Address already in use


Samebug tips3

Change the connection port and ip adress. If you're trying to connect to your server from your own computer, check if you haven't already connected to the server in another instance.

Try changing the port in core-site.xml from 9000 to 9001 as it seems port 9000 doesn't work.

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.


Solutions on the web4266

Solution icon of coderanch
via Coderanch by shreyansh jain, 8 months ago
Address already in use

Solution icon of coderanch
via Coderanch by Jacksy Verghese, 8 months ago
Address already in use

Solution icon of coderanch
via Coderanch by Danish Shaukat, 8 months ago
Address already in use

Solution icon of bugzilla
Address already in use

Solution icon of bugzilla
via Netbeans Bugzilla by dmladek, 1 month ago
Address already in use

Solution icon of github
via GitHub by jpdna
, 9 months ago
Address already in use

Solution icon of github
via GitHub by voellm
, 10 months ago
Address already in use

Solution icon of github
via GitHub by ilovemaui
, 7 months ago
Address already in use

Solution icon of github
via GitHub by mkjsix
, 1 year ago
Address already in use

Solution icon of github
via GitHub by RovertS
, 1 year ago
Address already in use

Stack trace

  • java.net.BindException: Address already in use at sun.nio.ch.Net.bind0(Native Method) at sun.nio.ch.Net.bind(Net.java:433) at sun.nio.ch.Net.bind(Net.java:425) at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223) at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74) at org.eclipse.jetty.server.ServerConnector.open(ServerConnector.java:321) at org.eclipse.jetty.server.AbstractNetworkConnector.doStart(AbstractNetworkConnector.java:80) at org.eclipse.jetty.server.ServerConnector.doStart(ServerConnector.java:236) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68) at org.eclipse.jetty.server.Server.doStart(Server.java:366) at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68) at org.apache.ignite.internal.processors.rest.protocols.http.jetty.GridJettyRestProtocol.startJetty(GridJettyRestProtocol.java:220) at org.apache.ignite.internal.processors.rest.protocols.http.jetty.GridJettyRestProtocol.start(GridJettyRestProtocol.java:177) at org.apache.ignite.internal.processors.rest.GridRestProcessor.startProtocol(GridRestProcessor.java:866) at org.apache.ignite.internal.processors.rest.GridRestProcessor.startHttpProtocol(GridRestProcessor.java:837) at org.apache.ignite.internal.processors.rest.GridRestProcessor.start(GridRestProcessor.java:451) at org.apache.ignite.internal.IgniteKernal.startProcessor(IgniteKernal.java:1549) at org.apache.ignite.internal.IgniteKernal.start(IgniteKernal.java:876) at org.apache.ignite.internal.IgnitionEx$IgniteNamedInstance.start0(IgnitionEx.java:1736) at org.apache.ignite.internal.IgnitionEx$IgniteNamedInstance.start(IgnitionEx.java:1589) at org.apache.ignite.internal.IgnitionEx.start0(IgnitionEx.java:1042) at org.apache.ignite.internal.IgnitionEx.start(IgnitionEx.java:549) at org.apache.ignite.internal.processors.platform.PlatformAbstractBootstrap.start(PlatformAbstractBootstrap.java:43) at org.apache.ignite.internal.processors.platform.PlatformIgnition.start(PlatformIgnition.java:73)[main]

Write tip

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

Users with the same issue

3 times, 8 months ago
Once, 2 days ago
36 times, 4 months ago
6 times, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
149 more bugmates