java.lang.UnsatisfiedLinkError

no jniopencv_core in java.library.path


Samebug tips1

This happens sometimes when Android fails to load the necessary libraries when you install an app. Try reinstalling it or telling your client to reinstall it, as it seems to correctly install the libraries and fixes the problem.

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.


Solutions on the web4573

Solution icon of github
via GitHub by jiekechoo
, 7 months ago
no jniopencv_core in java.library.path

Solution icon of github
no jniopencv_core in java.library.path

Solution icon of googlegroups
no jniopencv_core in java.library.path

Solution icon of stackoverflow
via Stack Overflow by PeterOtto
, 10 months ago
no jniopencv_core in java.library.path

Solution icon of web
via salaboy.com by Unknown author, 11 months ago
no jniopencv_core in java.library.path

Solution icon of github
via GitHub by SenhorCastor
, 1 year ago
no jniopencv_core in java.library.path

Solution icon of github
via GitHub by AlexDBlack
, 7 months ago
no jniopencv_core in java.library.path

Solution icon of github
no jniopencv_core in java.library.path

Solution icon of github
via GitHub by junyongyou
, 7 months ago
no jniopencv_core in java.library.path

Stack trace

  • java.lang.UnsatisfiedLinkError: no jniopencv_core in java.library.path at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1867) at java.lang.Runtime.loadLibrary0(Runtime.java:870) at java.lang.System.loadLibrary(System.java:1122) at org.bytedeco.javacpp.Loader.loadLibrary(Loader.java:801) at org.bytedeco.javacpp.Loader.load(Loader.java:613) at org.bytedeco.javacpp.Loader.load(Loader.java:530) at org.bytedeco.javacpp.helper.opencv_core$AbstractArray.<clinit>(opencv_core.java:109) at org.datavec.image.loader.NativeImageLoader.asMatrix(NativeImageLoader.java:184) at org.datavec.image.loader.NativeImageLoader.asMatrix(NativeImageLoader.java:177) at org.datavec.image.recordreader.BaseImageRecordReader.next(BaseImageRecordReader.java:208) at org.deeplearning4j.datasets.datavec.RecordReaderMultiDataSetIterator.next(RecordReaderMultiDataSetIterator.java:127) at org.deeplearning4j.datasets.datavec.RecordReaderMultiDataSetIterator.next(RecordReaderMultiDataSetIterator.java:95) at org.deeplearning4j.datasets.datavec.RecordReaderMultiDataSetIterator.next(RecordReaderMultiDataSetIterator.java:57) at org.deeplearning4j.datasets.datavec.RecordReaderMultiDataSetIteratorTest.testImagesRRDMSI(RecordReaderMultiDataSetIteratorTest.java:578)

Write tip

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 11 months ago
277 more bugmates