java.lang.IllegalArgumentException: Class android.support.v7.widget.SnapHelper$2 conflict: /Users/alexrainman/Desktop/nsappconnect/demo/platforms/android/build/intermediates/transforms/dex/F0F1/debug/folders/1000/1f/main/classes.dex and /Users/alexrainman/Desktop/nsappconnect/demo/platforms/android/build/intermediates/transforms/dex/F0/debug/folders/1000/1f/main/classes.dex

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via GitHub by alexrainman
, 11 months ago
Class android.support.v7.widget.SnapHelper$2 conflict: /Users/alexrainman/Desktop/nsappconnect/demo/platforms/android/build/intermediates/transforms/dex/F0F1/debug/folders/1000/1f/main/classes.dex and /Users/alexrainman/Desktop/nsappconnect/demo/platforms/android/build/intermediates/transforms/dex/F0/debug/folders/1000/1f/main/classes.dex
via GitHub by af-fess
, 11 months ago
Class android.support.v7.widget.AdapterHelper$UpdateOp conflict: /Users/maxim/Appsflyer/projects/nativescript-plugin-appsflyer/demoNative/platforms/android/build/intermediates/transforms/dex/F0F1/debug/folders/1000/1f/main/classes.dex and /Users
via GitHub by vchimev
, 11 months ago
Class android.support.v4.print.PrintHelper$PrintHelperImpl$2 conflict: /Users/vchimev/Work/release/TNS_App/platforms/android/build/intermediates/transforms/dex/F0F1/release/folders/1000/1f/main/classes.dex and /Users/vchimev/Work/release/TNS_App/platforms/android/build/intermediates/transforms/dex/F0F1/debug/folders/1000/1f/main/classes.dex
via Stack Overflow by dingyucong
, 11 months ago
Class android.support.v7.widget.SnapHelper$2 conflict: D:\app\toast-test\platforms\android\build\intermediates\transforms\dex\F0F1F2\debu
via GitHub by davidjonz2005
, 3 months ago
Class com.google.zxing.pdf417.PDF417ResultMetadata conflict: D:\dev\nativescript\ Salesman\platforms\android\build\intermediates\exploded-aar\barcodescanner-release-2.1.6\jars\classes.jar and C:\Users\A\.gradle\caches\modules- 2\files-2.1\com.google.zxing\core\3.2.1\2287494d4f5f9f3a9a2bb6980e3f32053721b315\core-3.2.1.jar
via GitHub by YonatanKra
, 2 months ago
Class android.support.v7.cardview.BuildConfig conflict: \Groceries\platforms\android\build\intermed iates\exploded-aar\com.android.support\cardview-v7\26.0.0-alpha1\jars\classes.jar and \Groceries\platforms\android\build\intermediates\exploded-aar\com.android.su pport\cardview-v7\25.3.1\jars\classes.jar
java.lang.IllegalArgumentException: Class android.support.v7.widget.SnapHelper$2 conflict: /Users/alexrainman/Desktop/nsappconnect/demo/platforms/android/build/intermediates/transforms/dex/F0F1/debug/folders/1000/1f/main/classes.dex and /Users/alexrainman/Desktop/nsappconnect/demo/platforms/android/build/intermediates/transforms/dex/F0/debug/folders/1000/1f/main/classes.dex
at com.telerik.metadata.ClassRepo.addToCache(ClassRepo.java:21)
at com.telerik.metadata.Builder.build(Builder.java:41)
at com.telerik.metadata.Generator.main(Generator.java:44)

Users with the same issue

You are the first who have seen this exception.

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.