jodd.http.HttpException

If you like a tip written by other Samebug users, mark is as helpful! Marks help our algorithm provide you better solutions and also help other users.
tip

Check if you don't have a VPN or something like this messing with your connection. Also, check Jenkins DNS configurations (try to start it with "--dns 8.8.8.8".

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • GitHub comment 4#273704536
    via GitHub by PeterWippermann
    ,
  • URL for Symantec VIP Web Service
    via by Unknown author,
  • Java couchdb4j DB connection
    via Stack Overflow by user1959214
    ,
  • App Factory 2.1.0 error when starting
    via Stack Overflow by Omar Flores
    ,
  • No hipchat notifications received. Also see this in the logs: Error posting to HipChat java.net.UnknownHostException: null at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:178) at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) at java.net.Socket.connect(Socket.java:579) at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:618) at sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:407) at sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:88) at hudson.util.NoClientBindSSLProtocolSocketFactory.createSocket(NoClientBindSSLProtocolSocketFactory.java:135) at hudson.util.NoClientBindSSLProtocolSocketFactory.createSocket(NoClientBindSSLProtocolSocketFactory.java:117) at org.apache.commons.httpclient.HttpConnection.open(HttpConnection.java:707) at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:387) at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171) at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397) at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:323) at jenkins.plugins.hipchat.StandardHipChatService.publish(StandardHipChatService.java:48) at jenkins.plugins.hipchat.ActiveNotifier.notifyStart(ActiveNotifier.java:53) at jenkins.plugins.hipchat.ActiveNotifier.started(ActiveNotifier.java:46) at jenkins.plugins.hipchat.HipChatNotifier$HipChatJobProperty.prebuild(HipChatNotifier.java:203) at hudson.model.AbstractBuild$AbstractBuildExecution.preBuild(AbstractBuild.java:806) at hudson.model.AbstractBuild$AbstractBuildExecution.preBuild(AbstractBuild.java:801) at hudson.model.AbstractBuild$AbstractBuildExecution.preBuild(AbstractBuild.java:797) at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:532) at hudson.model.Run.execute(Run.java:1740) at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43) at hudson.model.ResourceController.execute(ResourceController.java:88) at hudson.model.Executor.run(Executor.java:233) I tried going into global config and hitting save. Makes no difference, rolling back to 1.6 for now.
    via by Gennady Feldman,
    • jodd.http.HttpException: trans.gwtx01.com; <--- java.net.UnknownHostException: ------------ at jodd.http.HttpRequest.open(HttpRequest.java:702)[jodd-http.jar:3.8.1] at jodd.http.HttpRequest.open(HttpRequest.java:684)[jodd-http.jar:3.8.1] at jodd.http.HttpRequest._send(HttpRequest.java:782)[jodd-http.jar:3.8.1] at jodd.http.HttpRequest.send(HttpRequest.java:777)[jodd-http.jar:3.8.1] at com.ints.ccp.gateway.MerchantPartners.sendRequestToGateway(MerchantPartners.java:1359)[ccp.jar:na] at com.ints.ccp.gateway.MerchantPartners.sendRequestToGateway(MerchantPartners.java:1371)[ccp.jar:na] at com.ints.ccp.gateway.MerchantPartners.doTransaction(MerchantPartners.java:381)[ccp.jar:na] at com.ints.ccp.reader.Telium.runCreditDebit(Telium.java:1110)[ccp.jar:na] at com.ints.ccp.reader.Reader.runOperation(Reader.java:87)[ccp.jar:na] at com.ints.ccp.CCPMain.main(CCPMain.java:145)[ccp.jar:na] Caused by: java.net.UnknownHostException: ---------------- at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:184)[na:1.8.0_102] at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)[na:1.8.0_102] at java.net.Socket.connect(Socket.java:589)[na:1.8.0_102] at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:668)[na:1.8.0_102] at sun.security.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:427)[na:1.8.0_102] at sun.security.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:88)[na:1.8.0_102] at jodd.http.net.SocketHttpConnectionProvider.createSSLSocket(SocketHttpConnectionProvider.java:138)[jodd-http.jar:3.8.1] at jodd.http.net.SocketHttpConnectionProvider.createHttpConnection(SocketHttpConnectionProvider.java:73)[jodd-http.jar:3.8.1] at jodd.http.HttpRequest.open(HttpRequest.java:700)[jodd-http.jar:3.8.1]

    Users with the same issue

    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    derproggerderprogger
    52 times, last one,
    111 more bugmates