java.lang.UnsupportedClassVersionError

hudson/remoting/Launcher : Unsupported major.minor version 51.0


Samebug tips4

This might be caused by and outdated version of Java, SonarQube now uses Java 8 as default. You might upgrade java or use an older version of SonarQube.

If you're using intellij plugin of sonarqube, you might have to set the JAVA_HOME ambient variable manually.

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.


Solutions on the web4929

Solution icon of googlegroups
via Google Groups by rmpe...@gmail.com (JIRA), 7 months ago
hudson/remoting/Launcher : Unsupported major.minor version 51.0

Solution icon of github
via GitHub by gibfahn
, 1 week ago
hudson/remoting/Launcher : Unsupported major.minor version 51.0

Solution icon of googlegroups
via Google Groups by andreas...@gmail.com (JIRA), 7 months ago
hudson/remoting/Launcher : Unsupported major.minor version 51.0

Solution icon of stackoverflow
via Stack Overflow by user2964534
, 1 year ago
Launcher : Unsupported major.minor version 51.0

Solution icon of github
via GitHub by capnslipp
, 11 months ago
field/launch/Launcher : Unsupported major.minor version 51.0

Solution icon of github
via GitHub by marcdownie
, 11 months ago
field/launch/Launcher : Unsupported major.minor version 51.0

Solution icon of stackoverflow
via Stack Overflow by Illu Park
, 1 year ago
.../.../view/Launcher : Unsupported major.minor version 51.0

Solution icon of sourceforge
via freeplane by vlcvlc
, 1 year ago
org/freeplane/launcher/Launcher : Unsupported major.minor version 51.0

Solution icon of sourceforge
org/freeplane/launcher/Launcher : Unsupported major.minor version 51.0

Solution icon of web
via bitcointalk.org by Unknown author, 1 year ago
strat/mining/stratum/proxy/Launcher : Unsupported major.minor version 51.0

Stack trace

  • java.lang.UnsupportedClassVersionError: hudson/remoting/Launcher : Unsupported major.minor version 51.0 at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631) at java.lang.ClassLoader.defineClass(ClassLoader.java:615) at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141) at java.net.URLClassLoader.defineClass(URLClassLoader.java:283) at java.net.URLClassLoader.access$000(URLClassLoader.java:58) at java.net.URLClassLoader$1.run(URLClassLoader.java:197) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:190) at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClassFromSelf(ClassRealm.java:401) at org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy.loadClass(SelfFirstStrategy.java:42) at org.codehaus.plexus.classworlds.realm.ClassRealm.unsynchronizedLoadClass(ClassRealm.java:271) at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:254) at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:239) at jenkins.maven3.agent.Maven32Main.main(Maven32Main.java:143) at jenkins.maven3.agent.Maven32Main.main(Maven32Main.java:74)

Write tip

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Once, 2 months ago
2 times, 6 months ago
Samebug visitor profile picture
Unknown user
Once, 10 months ago
333 more bugmates