org.apache.catalina.LifecycleException

Failed to initialize component [Connector[HTTP/1.1-9006]]

Samebug tips3

It might be that there's another process connecting to the same port you're trying to use, try to kill it or change the connection port.


rafaelrafael

Change the connection port and ip adress. If you're trying to connect to your server from your own computer, check if you haven't already connected to the server in another instance.


rafaelrafael

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web912

  • via Super User by Antony Naveen
    ,
  • via Stack Overflow by PT_C
    ,
  • Stack trace

    • org.apache.catalina.LifecycleException: Failed to initialize component [Connector[HTTP/1.1-9006]] at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:106)[tomcat-embed-core-8.0.32.jar:8.0.32] at org.apache.catalina.core.StandardService.initInternal(StandardService.java:568)[tomcat-embed-core-8.0.32.jar:8.0.32] at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)[tomcat-embed-core-8.0.32.jar:8.0.32] at org.apache.catalina.core.StandardServer.initInternal(StandardServer.java:851)[tomcat-embed-core-8.0.32.jar:8.0.32] at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)[tomcat-embed-core-8.0.32.jar:8.0.32] at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:136)[tomcat-embed-core-8.0.32.jar:8.0.32] at org.apache.catalina.startup.Tomcat.start(Tomcat.java:345)[tomcat-embed-core-8.0.32.jar:8.0.32] at org.sonar.server.app.EmbeddedTomcat.start(EmbeddedTomcat.java:62)[sonar-server-5.6.4.jar:na] at org.sonar.server.app.WebServer.start(WebServer.java:42)[sonar-server-5.6.4.jar:na] at org.sonar.process.ProcessEntryPoint.launch(ProcessEntryPoint.java:102)[sonar-process-5.6.4.jar:na] at org.sonar.server.app.WebServer.main(WebServer.java:68)[sonar-server-5.6.4.jar:na] Caused by: org.apache.catalina.LifecycleException: Protocol handler initialization failed at org.apache.catalina.connector.Connector.initInternal(Connector.java:962)[tomcat-embed-core-8.0.32.jar:8.0.32] at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)[tomcat-embed-core-8.0.32.jar:8.0.32] ... 10 more Caused by: java.net.BindException: Cannot assign requested address at sun.nio.ch.Net.bind0(Native Method)[na:1.8.0_111] at sun.nio.ch.Net.bind(Net.java:433)[na:1.8.0_111] at sun.nio.ch.Net.bind(Net.java:425)[na:1.8.0_111] at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223)[na:1.8.0_111] at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)[na:1.8.0_111] at org.apache.tomcat.util.net.NioEndpoint.bind(NioEndpoint.java:340)[tomcat-embed-core-8.0.32.jar:8.0.32] at org.apache.tomcat.util.net.AbstractEndpoint.init(AbstractEndpoint.java:742)[tomcat-embed-core-8.0.32.jar:8.0.32] at org.apache.coyote.AbstractProtocol.init(AbstractProtocol.java:458)[tomcat-embed-core-8.0.32.jar:8.0.32] at org.apache.coyote.http11.AbstractHttp11JsseProtocol.init(AbstractHttp11JsseProtocol.java:120)[tomcat-embed-core-8.0.32.jar:8.0.32] at org.apache.catalina.connector.Connector.initInternal(Connector.java:960)[tomcat-embed-core-8.0.32.jar:8.0.32] ... 11 more

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    esaaresaar
    4 times, last one
    Unknown visitor
    Unknown visitorOnce,
    linxiaolonglinxiaolong
    Once,
    kuldeepkuldeep
    12 times, last one
    Unknown visitor
    Unknown visitorOnce,
    141 more bugmates