org.jboss.weld.resources.spi.ResourceLoadingException

tip

Check if the version of resteasy is using is the same JBoss is using. To find it out, search for resteasy-jaxrs* in JBoss/Wildfly directory and at your pom.xml.

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • Activiti Issues
    via by Joao Bpmn,
  • db:: 4.45::A custom Weld Java SE startup class f7
    via by Unknown author,
  • db:: 3.55::JSF 1.1.X in JBOSS 5.1.0 7k
    via by Unknown author,
  • 7月 2011 - るいもの戯れ言
    via by Unknown author,
  • Working MDB example in JBoss 7.0.1?
    via Stack Overflow by Andrew Regan
    ,
    • org.jboss.weld.resources.spi.ResourceLoadingException: java.lang.ClassNotFoundException: org.activiti.cdi.impl.annotation.StartProcessInterceptor from [Module "deployment.teste-sem-maven.war:main" from Service Module Loader]; location: <class>org.activiti.cdi.impl.annotation.StartProcessInterceptor</class> in vfs:/C:/jboss-as-web-7.0/standalone/deployments/teste-sem-maven.war/WEB-INF/beans.xml@7 at org.jboss.as.weld.services.WeldService.start(WeldService.java:96) at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1765) at org.jboss.msc.service.ServiceControllerImpl$ClearTCCLTask.run(ServiceControllerImpl.java:2291) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)[:1.6.0_20] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)[:1.6.0_20] at java.lang.Thread.run(Thread.java:619)[:1.6.0_20] Caused by: org.jboss.weld.resources.spi.ResourceLoadingException: java.lang.ClassNotFoundException: org.activiti.cdi.impl.annotation.StartProcessInterceptor from [Module "deployment.teste-sem-maven.war:main" from Service Module Loader]; location: <class>org.activiti.cdi.impl.annotation.StartProcessInterceptor</class> in vfs:/C:/jboss-as-web-7.0/standalone/deployments/teste-sem-maven.war/WEB-INF/beans.xml@7 at org.jboss.weld.manager.Enabled$ClassLoader.apply(Enabled.java:75) at org.jboss.weld.manager.Enabled$ClassLoader.apply(Enabled.java:56) at com.google.common.collect.Lists$TransformingRandomAccessList.get(Lists.java:435) at java.util.AbstractList$Itr.next(AbstractList.java:345)[:1.6.0_20] at org.jboss.weld.manager.Enabled.createMetadataMap(Enabled.java:143) at org.jboss.weld.manager.Enabled.<init>(Enabled.java:113) at org.jboss.weld.manager.Enabled.of(Enabled.java:95) at org.jboss.weld.bootstrap.BeanDeployment.<init>(BeanDeployment.java:104) at org.jboss.weld.bootstrap.WeldBootstrap$DeploymentVisitor.visit(WeldBootstrap.java:185) at org.jboss.weld.bootstrap.WeldBootstrap$DeploymentVisitor.visit(WeldBootstrap.java:156) at org.jboss.weld.bootstrap.WeldBootstrap.startContainer(WeldBootstrap.java:293) at org.jboss.as.weld.WeldContainer.start(WeldContainer.java:79) at org.jboss.as.weld.services.WeldService.start(WeldService.java:89) ... 5 more Caused by: java.lang.ClassNotFoundException: org.activiti.cdi.impl.annotation.StartProcessInterceptor from [Module "deployment.teste-sem-maven.war:main" from Service Module Loader] at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:191) at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:358) at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:307) at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:101) at org.jboss.as.weld.WeldModuleResourceLoader.classForName(WeldModuleResourceLoader.java:68) at org.jboss.weld.manager.Enabled$ClassLoader.apply(Enabled.java:71) ... 17 more

    Users with the same issue

    Unknown visitor
    Unknown visitor1 times, last one,
    Andreas HäberAndreas Häber
    1 times, last one,
    ivanszkypeterivanszkypeter
    1 times, last one,
    MoYaproMoYapro
    2 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    81 more bugmates